WordPress.org

Ready to get started?Download WordPress

Forums

TablePress
[resolved] Links not working (8 posts)

  1. realpatidar
    Member
    Posted 11 months ago #

    The links inserted in the table using Advanced Editor (or even directly) are not working.

    My Webpage is http://www.realpatidar.com/library

    The HTML code for link is <a href="http://www.realpatidar.com/wp-content/files/library/lib0001.html" target="_blank">Free</a>

    http://wordpress.org/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 11 months ago #

    Hi,

    thanks for your post, and sorry for the trouble.

    This is indeed really strange. The HTML code for your links is correct, and if JavaScript is turned off on the page, the links work fine. My assumption therefore is that there's some JavaScript code on the page that is influencing links, but that's somehow broken (for example some JS that counts clicks for statistical purposes).

    To be sure that this is not caused by TablePress or its included DataTables JS library, please temporarily uncheck the "Use DataTables" checkbox on the "Edit" screen of the table.

    If the links still don't work after that, the cause for the problem must be in some other JavaScript that is loaded into the page, e.g. by your theme or another plugin. In that case, you'll need to temporarily deactivate other plugins one by one, and switch to the WordPress Default theme TwentyTwelve, until the links work.

    Regards,
    Tobias

  3. realpatidar
    Member
    Posted 11 months ago #

    Yes, you are right.

    The problem is incompatibility with "Electric Studio Download Counter" plugin. After deactivating this plugin the issue got resolved.

    Thanks for your help.

    Real Patidar

  4. TobiasBg
    Member
    Plugin Author

    Posted 11 months ago #

    Hi,

    great to hear that you found the cause for this!
    It looks like other people have the same problem with their links:
    http://wordpress.org/support/topic/wont-let-my-users-download-my-files

    It seems that the plugin author is not responding, but someone has a suggested a fix in that forums thread. Maybe you can try that.

    Best wishes,
    Tobias

  5. adriaan47
    Member
    Posted 4 months ago #

    Hi Tobias and other word-pressers

    i'm a new-be and just starting to use table-press

    i want to use it for placing thumbs of artists (20) in one page with a small description of what there activities
    then i want to link them , by clicking on the thumbs, to the page with the hole profile of the artist and his gallerie.
    i think i working following your instructions ,
    clicking on the link button
    going to the field ,
    getting the form screen,
    clic on the page i want to go to
    ad the link
    and save.
    but
    sometimes its working and sometimes not.
    sometimes a caption with a link is placed above the the thumbs,
    sometimes below but it never works when i click on the thumbs self,
    but thats whats i wanted.

    i think its has to do with the place where i set the cursor in the field where the thumbs are located. is that so?

    so what do i have to do to get the link on the thumbs its self

    btw i'am dutch so forgive my the bad english i hope you understand my question

    Greetings Adriaan

  6. TobiasBg
    Member
    Plugin Author

    Posted 4 months ago #

    Hi Adriaan,

    thanks for your post, and sorry for the trouble.

    To make thumbnails/images clickable, I suggest to insert them (together with the link) via the "Insert image" button below the table input fields.
    In the popup, you can then select the image, and also put in the desired "Link Target".
    By doing that, the links will automatically link to that target, without you having to use the "Insert Link" button as well.

    Regards,
    Tobias

  7. adriaan47
    Member
    Posted 4 months ago #

    Hi Tobias,

    Thanks for your reaction its works very well that way.
    great job.

    i still have one request
    the thumbs do have already a name and description
    the profile page has de same name as the thumb
    so now i have in the table twice the name of the artist.
    i think that's confusion for the visters of the site.
    Is it possible that the existing name and description works as a link
    or is the only solution that i change the name in the profile pages to
    profil of Artistname.

    I like to hear from you,

    Regards Adriaan

  8. TobiasBg
    Member
    Plugin Author

    Posted 4 months ago #

    Hi,

    good to hear that this helped.

    I'm not sure what the best approach here is, but you could simply try whatever works best for you.
    In TablePress, it's simply a matter of getting the HTML for the image and the caption correct.

    Regards,
    Tobias

Reply

You must log in to post.

About this Plugin

About this Topic