WordPress.org

Ready to get started?Download WordPress

Forums

TablePress
[resolved] Links not working (9 posts)

  1. davegrun
    Member
    Posted 1 year ago #

    Hello, I insert the link and it appears in the row. But when I save or preview the links in the table do not work. Please tell me what may be wrong.

    http://wordpress.org/extend/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for your post, and sorry for the trouble.

    Can you please explain what "do not work" means here? What happens when you click on the link?

    Please post a link to the page with the table, so that I can take a direct look. Thanks!

    Regards,
    Tobias

  3. davegrun
    Member
    Posted 1 year ago #

    Hi Tobias,

    What I mean is that I enter a link as per the instructions but no link appears in the live page. I check the table and html code of the link is there but when I preview or publish-the text is not hyperlinked. Please help.

  4. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I will gladly try to help, so please post a link to the page with the table, as I can't help otherwise.

    Regards,
    Tobias

  5. davegrun
    Member
    Posted 1 year ago #

    Here is the page: http://www.gts-translation.com/page-frenchenglish-culinary-dictionary/

    The value 'au milieu de' in the left column is linked in Tablepress but the link does not work

    [Oh - be serious! No bumping. If it's that urgent, consider hiring someone.]

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @davegrun - that's really a bit much - considering that Tobias is one of the MOST responsive and helpful plugin devs I've ever seen... an hour is hardly a long wait.

    EDIT - looks like another moderator posted a note above - same thing...

  7. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for link! No I can see what the problem is.
    Basically, the HTML code the links is missing the link text. Instead, that link text is standing outside of the link.
    An example:

    au milieu de<a href="http://gts-translation.com" target="_blank"></a>

    actually should be

    <a href="http://gts-translation.com" target="_blank">au milieu de</a>

    I.e., the link text (the text that you want to be clickable) needs to stand right before </a> in the link HTML code.

    Regards,
    Tobias

  8. davegrun
    Member
    Posted 1 year ago #

    Thanks Tobias, I got it to work. When you click 'Insert Link' you need to select the link text and not just click inside the cell. The popup instruction was unclear to me.

    I appreciate your help and 'bumped' you because I wanted to get this over with. No negative vibes intended and it is a good plugin. However, it looks like some of the moderators may be suffering from post-weekend blues. Either that or they don't have much going on this AM.

    Thanks again, Dave

  9. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Dave,

    great to hear that this helped! :-)
    Yes, you need to select the link text and not just click in it, or type it into the text field in the popup.

    Best wishes,
    Tobias

    P.S.: In case you haven't, please rate TablePress here in the plugin directory. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.