WordPress.org

Ready to get started?Download WordPress

Forums

EasyRotator for WordPress - Slider Plugin
[resolved] Links not re-directing in slide (9 posts)

  1. OfficialMagicPgCom
    Member
    Posted 1 year ago #

    Love the plugin. Just recently started having a problem where the slider is not taking a user to the corresponding link associated with the slide. Any insight?

    http://wordpress.org/extend/plugins/easyrotator-for-wordpress/

  2. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thanks for using EasyRotator for WordPress! Can you please send the URL of your page and confirm in which browser(s) you're seeing the problem? Please also let me know which is the problematic slide.

    Sincerely,
    Drew O'Neill

  3. OfficialMagicPgCom
    Member
    Posted 1 year ago #

    Thanks for the quick response.

    URL - http://www.officialmagicpg.com

    Browser - Chrome

    All slides not working.

  4. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    There are quite a few script in your page (unrelated to the rotator) that are raising JavaScript errors, and these other scripts appear to be interfering with links. Here's some code you can add to the footer.php template file just before </body> to restore link functionality:

    (Get code here: https://gist.github.com/anonymous/9d59abc50cb702fd17d4 )

    The better solution, though, is to use the View > Developer > JavaScript Console window in Google Chrome to identify and correct the errors in your page.

    Sincerely,
    Drew O'Neill

  5. OfficialMagicPgCom
    Member
    Posted 1 year ago #

    Thanks Drew. I will check out both provided solutions.

  6. OfficialMagicPgCom
    Member
    Posted 1 year ago #

    I entered the code but it did not fix the problem. Any update?

  7. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Again, the best option is to locate the other script that's interfering and address that. But here's another updated script that should allow the links to be restored: https://gist.github.com/anonymous/1328cbc184a17e3f2bd1

    Sincerely,
    Drew O'Neill

  8. OfficialMagicPgCom
    Member
    Posted 1 year ago #

    Much appreciated. I will look into seeing which scripts are causing the problem.

  9. OfficialMagicPgCom
    Member
    Posted 1 year ago #

    It seems the loginradius plugin is interfering.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic