WordPress.org

Ready to get started?Download WordPress

Forums

Links in WordPress dashboard on local wamp install (3 posts)

  1. Julian Fox
    Member
    Posted 5 months ago #

    Hi,

    I recently decided to setup a test server on my local machine to test plugins before activating them on my live mirror site. I have just noticed that WordPress has Links in the main dashboard, there are no links in there and i did not install the wp-links plugin that the codex talks about. My Live mirror site does not have the links button, however when i setup the local install i manually set up each part and downloaded fresh copies of each plugin.

    So I am wondering how did i activate the Links menu on my local install of WordPress, I am pretty sure i did everything the same as the set up for my Live install. If i had of just copied the DB and files and folders to my local machine i would imagine this wouldn't occur, but i wanted to replace my live site with a fresh copy of WordPress and essential plugins only.

    I know this is only a little thing, but i'm just curious because i don't want any security holes or anything unexpected since this website will be for a legitimate client using payment gateways.

    Any insights or explanations would be helpful. :)

    Here is a picture of the Links menu - http://bit.ly/1kvgPQr

  2. ClaytonJames
    Member
    Posted 5 months ago #

    Usually that only occurs if you had active links prior to version 3.5, and then the link manager would carry over and remain visible during any subsequent WordPress upgrades. As for how it got turned on, if you didn't import a database, it's hard to say. Two things you might try, given that it's a brand new installation:

    a) you could leave the files as they are and just clear the database tables, then re-run the install routine. Check for the link manager right after installation, then check for it after you activate each new plugin to see if one of those may have turned it on.

    b) you can just turn it off. Log in, then type yoursite.com/wp-admin/options.php in your browser. You should find a setting there labeled "link_manager_enabled". 0 turns it off, 1 leaves it on. The Save Changes button is at the bottom of the page.

  3. Julian Fox
    Member
    Posted 5 months ago #

    Thats helpful info thanks.

    Ill do what you suggested first A and then who knows i might keep it, i might use it. didnt even know WordPress had a links manager.

    Thanks for your reply, ill post the results of my tests and then resolve this topic incase anyone else is curious or has a problem relating to this.

Reply

You must log in to post.

About this Topic