WordPress.org

Ready to get started?Download WordPress

Forums

Links in sidebar no longer working (3 posts)

  1. starlucent
    Member
    Posted 7 years ago #

    My blog (www.free-from.com/blog) was working fine until I upgraded WP - since then I've realised that the links in my sidebar (archive, category and related posts) aren't working - I just get the first page again. And according to my logs, visitors following a link to, say, a christmas cake recipe posted in October, are just getting the first page (November) too, and can't get to October.

    I've checked my permalinks, and tried setting them again to friendly links (though I notice that somewhere along the line the system forgot to use the friendly links, and I've got numbers in my recent posts - is there a way of resetting these?).

    I've tried looking at the .htaccess file too, as recommended in other requests for help, but don't really know what to do with this, or what it should look like.

    Can anybody help? What have I done wrong? I'm going to try switching off all my plug-ins one-by-one to see if that helps ...

  2. Michael Bishop

    Posted 7 years ago #

    Looks like that section is commented out, look at the source.

    <!--
    Just above the template tag for links and --> just below the meta.

    Remove those and see what happens.

    (sidebar.php file)

  3. starlucent
    Member
    Posted 7 years ago #

    Thanks for the suggestion. I have uncommented various pieces of the code (I'd commented out meta, for instance) but it hasn't solved my problem (www.free-from.com/blog).

    I used to have the permalinks set to month/day/postname, and it worked fine. Now, it no longer works.

    If I reset the permalink structure to the default, I can navigate to my archives, and between posts, with no problem. If I reset the permalink to month/day/postname, using the radio buttons on the permalinks page of the control panel, then I can no longer navigate, and all links simply refresh the home page.

    I've read through dozens of posts and attempted various solutions that have worked for others, and am at a loss to know how to proceed.

    I don't want the default option, nor the index.php option if I can avoid it. What has changed? I have deactivated all the plugins I was using, and don't know what else to try.

    Does anybody have any ideas? Please?

Topic Closed

This topic has been closed to new replies.

About this Topic