WordPress.org

Ready to get started?Download WordPress

Forums

BFT Autoresponder and Newsletter
[resolved] Links in html code (33 posts)

  1. WordPressUser
    Member
    Posted 1 year ago #

    Hello,

    I have a problem with links and quotes in html code...

    a href=\\\\"http://mysite.com\\\\">mysite.com</

    \\\\

    Thank you for that excellent plugin !

    http://wordpress.org/extend/plugins/bft-autoresponder/

  2. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your feedback. Could you do the following:

    1. Upgrade to 1.7.2
    2. Remove the slashes manually once (or recreate the messages). Sorry, the update will not be able to fix old messages automatically

    The problem should not appear from now on

  3. WordPressUser
    Member
    Posted 1 year ago #

    Hello,

    Thank you, but I have always the same problem on a new message :

    <a href=\"http://site.com/a.php?{{email}}\">http://site.com/a.php?{{email}}</a>

    Have you a solution ?

    Merry christmas

  4. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    Where exactly are you seeing this? In the edit message area?

  5. WordPressUser
    Member
    Posted 1 year ago #

    I am seeing this in edit area and in messages received.

    \ appears when I save a message.

  6. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    I have no idea how is that possible after installing the new version.

  7. WordPressUser
    Member
    Posted 1 year ago #

    Maybe data's structure is still the same ?

  8. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    It's not related to data structure. There is stripslashes() call in the edit quiz HTML code. It's just impossible that these slashes would be shown, so I have no idea what's the problem in your case. I'm sorry I cannot guess. I'll need full admin and FTP access to have a look although I am not very keen on providing free support on individual bases. I am busy.

  9. The Man Sphere
    Member
    Posted 1 year ago #

    I just installed it for the first time. 1.7.2. And I concur. As I create and save my test messages, the slashes appear.

    For instance, I used the subject line What's Up?

    It saved (and sent) the subject line What\\\'s up?

    I sent the body text: So here's a message.

    I received the body text: So here\'s a message.

    Thinking this is more than an individual support issue. And yes, my everything else is up to date and functional.

  10. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed in 1.7.3

  11. The Man Sphere
    Member
    Posted 1 year ago #

    Wow...that upgrade deleted the mailing list and all previous emails! Let's see what it does with the slashes. I'll get back to you in a minute.

  12. The Man Sphere
    Member
    Posted 1 year ago #

    K, got the messages back. Messages come from (unknown sender). The slashes are still there in the subject line.

    In the mailer back office, it's a single slash in the subject line (Here\'s a message)

    In the actual message, it's three slashes: Here\\\'s a message

    I'm interested in buying the PRO version, so if this bug can get squashed I think it's a HUGE product for WP admins and users.

  13. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    The upgrade doesn't delete anything unless you uninstall manually which you shouldn't do. It onlu removed slashes.

  14. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    Slashes will not disappear, it's just that new ones will not be added. So please cleanup your messages once and no new slashes will appear.
    Slashes removed from subject in 1.7.4
    "Unknown sender" is displayed most probably because you don't have sender's address defined in the settings page.
    Once again, do not uninstall the plugin. Either use the automated updater or deactivate, upload by FTP and upload. Using the uninstall (delete) deletes all the data as well.

  15. WordPressUser
    Member
    Posted 1 year ago #

    I\'m not alone.

    ;-)

  16. The Man Sphere
    Member
    Posted 1 year ago #

    This was in a subject line on a new message after the upgrade to 1.7.3

  17. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    See above, slashes removed from subjects in 1.7.4

  18. The Man Sphere
    Member
    Posted 1 year ago #

    I set the BFT Autoresponder > Options > Main Settings to a sender name and saved. That was step 1.

    Input a new message with the subject line: Here's a message.

    It saved it as: Here\'s a message.

    It sent it as: (unknown sender) Here\\\'s a message.

  19. WordPressUser
    Member
    Posted 1 year ago #

    Can you remove slashes in bft\\\'s support in 1.7.5 ?

  20. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    I don't have any of this in 1.7.4. There are no slashes in the subject and sender is fine.

  21. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    I don't get it. What slashes in bft's support?

  22. WordPressUser
    Member
    Posted 1 year ago #

    It\\\\\'s a joke.

  23. The Man Sphere
    Member
    Posted 1 year ago #

    Don't waste his time. We're working here.

    Just waiting on a new test on 1.7.4

  24. The Man Sphere
    Member
    Posted 1 year ago #

    K, no slashes in the back office version. Now down to one slash in the subject line in the email I received (Here\'s a new message)

    Still coming from a (unknown sender)

  25. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    I uploaded 1.7.5 because of a possible slash in subject while sending email, so you'd better hold of a min and update right to it.

  26. The Man Sphere
    Member
    Posted 1 year ago #

    K I'm just waiting to see 1.7.5 in the updates. It's not there yet.

  27. The Man Sphere
    Member
    Posted 1 year ago #

    Alright! Slashes are all gone!

    Buuuut....still unknown sender.

  28. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    Could you enter my email in your system - handzhiev at gmail.com
    I want to see in full headers why you have unknown sender

  29. The Man Sphere
    Member
    Posted 1 year ago #

    K...let me know if you get it.

  30. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have valid email address in sender field? I see "Your Personal Reset Button". You need valid email, not just name.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.