WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Links Go To 404 When Setting Permalink Structure To /%postname%/ (7 posts)

  1. cashplanet
    Member
    Posted 6 years ago #

    I'm experiencing a problem when I use a custom
    permalink structure for some reason.

    The default structure works fine but when I change
    it to /%postname%/ it goes to the 404 page for my
    domain when you click on the individual post.

    I can't seem to understand why as this custom structure
    works fine on my other WP blog (although its an older
    version of WP 2.0). This domain has the same 404 set up.

    Here is my older WP blog where it works fine:
    http://www.marketingoasis.com/blog/

    Here is my new WP blog where it doesn't work:
    http://www.instanthotrodpills.com/blog/

    Any help would be much appreciated. I'm guessing it
    might have something to do with the new WP 2.5.1 but
    I'm not exactly sure.

    Thanks,
    Tristan

  2. iridiax
    Member
    Posted 6 years ago #

    Don't use only /%postname%/ as your permalink structure because you'll only have problems. There really should be a sticky or something warning people not to try this.

  3. cashplanet
    Member
    Posted 6 years ago #

    So what is the alternative if you want the post title in
    the link (to help the rankings in the search engines).

    If there is no alternative I may have to go back and use
    WP 2.0 because I must have this permalink structure.

    Anyone got any ideas about how to get the post title
    in the link without any problems (using WP 2.5.1).

  4. iridiax
    Member
    Posted 6 years ago #

    For one site I use:

    /%year%/%monthnum%/%day%/%postname%/

    And for another I use the following (all posts are in the default category, which has the name of my major keyword):

    /%category%/%postname%/

  5. cashplanet
    Member
    Posted 6 years ago #

    I would be happy with that but nothing seems to work.

    I have tried all of the other permalink options but
    only the default option works, very strange.

    Something is definitely wrong here, not sure what
    to do as I don't want the default option.

  6. iridiax
    Member
    Posted 6 years ago #

    It now sounds like an .htaccess and/or server issue.

  7. cashplanet
    Member
    Posted 6 years ago #

    Yes, I just realised. I hadn't set up a
    WP blog for so long I forgot about it.

    Just went into Web Shell and set it up
    and all is working fine now.

    Thanks for your help iridiax, I appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic