WordPress.org

Ready to get started?Download WordPress

Forums

links broken after MySQL id reset (4 posts)

  1. RobR
    Member
    Posted 7 years ago #

    Good morning.

    I have done a search and don't seem to be able to find anything related to my problem.

    I use custom permalinks /%post_id% so that each post is sequential, my blog is very simple http://engtect.net

    a few days ago I created a page, played with it and then deleted it as it took up a post id and so messed up my layout. I then went into PHPMyAdmin to reset the post id so that the next one would be correct. I.e. my current post was 28 so I changed the next auto increment from 30 to 29.

    This morning I make a post and the link to it will not work, be in from the font page, a single page or in the admin area.

    I have had a little look around phpmyadmin for clues as to what I have messed up but am none the wiser. Any ideas?

  2. Chris_K
    Member
    Posted 7 years ago #

    Messing with those ids is never fun, is it?

    Did you check post2cat to see if there are any orphan or invalid records for the current post's ID? Probably would want to look at postMeta as well.

  3. RobR
    Member
    Posted 7 years ago #

    Yeah I did but I admit that I am not sure what orphan or invalid records are. I will try searching now. If you or anyone can give those two tables a look and see if you can spot anything that would be great. here are the jpg for them:
    http://www.rieder.co.uk/downloads/post2cat.jpg
    http://www.rieder.co.uk/downloads/post2cat.jpg

    Will report back!

  4. RobR
    Member
    Posted 7 years ago #

    I should mention that I am running no plugins.

Topic Closed

This topic has been closed to new replies.

About this Topic