WordPress.org

Ready to get started?Download WordPress

Forums

Links and css not showing with MAMP (13 posts)

  1. Takkemike
    Member
    Posted 1 year ago #

    For developing I installed MAMP and the WordPress installation went flawless. But… the links and styling don't show up in the browser.

    Searching the web and this forum gave some hints on how to solve it.
    I changed both URL's in the Settings from http://localhost:8888/(nameofthewordpresssite) to http://(ip-address):8888/(nameofthewordpresssite). No solution and there's probably more to this.

    Did anyone have the same issue and found the solution? What else do I have to fix/

    Thanks in advance for any advice/tips!

  2. ak.singla
    Member
    Posted 1 year ago #

    Is it the correct path that is visible in the browser when you run your local server?

    Place the site address in the admin Settings -- same as the one it shows in the browser address bar.

  3. Archie22is
    Member
    Posted 1 year ago #

    Sometimes it can be a problem with your tags. I see the problem often in my development team - I or the other guys on Windows would miss or have extra html tags on the Windows machines and everything would work but the Mac users will then get errors.

    Double check the html tags and also your php syntax.

  4. Takkemike
    Member
    Posted 1 year ago #

    Thanks! Just tried this and immediately had to re-login. (The imputfields for WordPress were yellow instead of pink, by the way) Unfortunately, this didn't solve the broken links.

  5. ak.singla
    Member
    Posted 1 year ago #

    Are the elements aligned as per CSS file??

  6. Archie22is
    Member
    Posted 1 year ago #

    :: So the installation went wrong from the very start, right after the installation?

  7. Takkemike
    Member
    Posted 1 year ago #

    Did you mean whether they have a class? If so, yes the do. Also I typed some blabla in the header.php to make sure there shows up anything.

    (Sorry, I had a phone call) The installation seemed pretty good. I'm working from scratch with a custom theme which is pretty clean at the moment. But I guess the paths are incorrect.

  8. Takkemike
    Member
    Posted 1 year ago #

    Maybe it's good to add that the folder I put the WordPress sites in are not in the Applications>MAMP>htdocs, but somewhere else on my HD.

  9. ak.singla
    Member
    Posted 1 year ago #

    By that I mean, is it picking up the CSS file ?? As you said links are not working .. does that mean now the css is working ??

    I'm working from scratch with a custom theme which is pretty clean at the moment. But I guess the paths are incorrect.

    -->A new installations should set the paths by itself.

  10. ak.singla
    Member
    Posted 1 year ago #

    And there you are. . .
    Move them to the right place, and it should work.

  11. Archie22is
    Member
    Posted 1 year ago #

    The folder has to be inside the Mamp->htdocs or the Php will not run.

  12. Takkemike
    Member
    Posted 1 year ago #

    Partly solved… I bluntly put the missing image in a browser and copied the path to img src. Chopping off bits lead to the image popping up. This path is the one I have to give to the css.

    Still I have no clue how (or if) this path should be copied to the WordPress URL in settings.

  13. Takkemike
    Member
    Posted 1 year ago #

    Getting close now :)
    Thank you for the support!

Topic Closed

This topic has been closed to new replies.

About this Topic