WordPress.org

Ready to get started?Download WordPress

Forums

Linking to my WP blog on Facebook doesn't show correctly (2 posts)

  1. Emily
    Member
    Posted 1 year ago #

    Hi Everyone.

    My blog is located here: http://www.oh-i-see.com/blog/

    Every day, I post on Facebook a link to the most recent blog article. Unfortunately, they end up coming out without images or the title of my blog or the meta tag. You can see a few examples on the authors FB page here: https://www.facebook.com/JanineOICMoments

    For whatever reason, after the article has been up roughly a week, if we go to post it again, it does appear (see March 11). I'm trying to figure out if there's a way for my initial postings, when the articles are most relevant, to get the content to show up. I sincerely appreciate any help you can offer.

    Theme: Esquire
    How I'm posting: Clicking on blog title on my blog, copying URL, opening FB, pasting link in the "Share What You've Been Up To" Field.

    Thanks in advance for your help.
    Emily

  2. Jess
    Member
    Posted 1 year ago #

    Facebook has some debugging tools for links that can help the platform find the pieces you want it to find: http://developers.facebook.com/tools/debug

    Also, you could try using a plugin that automatically posts anything new to Facebook from your blog - start with this search: http://wordpress.org/extend/plugins/search.php?q=facebook&sort=

    JetPack has some social media features as well: http://wordpress.org/extend/plugins/jetpack/

Topic Closed

This topic has been closed to new replies.

About this Topic