WordPress.org

Ready to get started?Download WordPress

Forums

Spun
[resolved] linking to different posts within a post (10 posts)

  1. Sexta Feira
    Member
    Posted 1 year ago #

    hi, i'm just learning so sorry if this has already been answered (tried looking for it and no luck) or if it's something really simple. Basically I would like to have various pictures of the same thing on my 'home page' but when you click on one circle to view an object, in the post, below the original picture and description, you will see the other posts that also appear of the same object from my site, and ideally, they would appear as on the home page, in the shape of a circle and not a square, and they would link you to the post for that object (the same as if you had clicked on that circle from the home page)....does this makes sense? i can't link b/c i'm developing from a local server.

    thanks for any help!

  2. Caroline Moore
    Member
    Theme Author

    Posted 1 year ago #

    I'm not sure what you're trying to do based on your description. Maybe you want to display related/relevant posts on single post view? If so, there are plugins to do that, then you can use the same styles from the theme's style.css to make the posts look the same.

    Otherwise I don't think this is something I can help with, since it sounds like a pretty advanced customization. Sorry!

  3. Sexta Feira
    Member
    Posted 1 year ago #

    I think I've made it more complicated than I should have, especially trying to explain it to you, so essentially my question is how do i add images to a post and get them to appear as they do on the home page (as a circle) and not as the original image (rectangular/square)?

  4. Caroline Moore
    Member
    Theme Author

    Posted 1 year ago #

    Couple things you could do.

    You can create a Gallery formatted post and upload some posts to it. That will automatically add a gallery of images styled as circles above the post content, like what you see on the demo:
    http://spun-demo.calobeedoodles.com/2008/06/10/post-format-test-gallery/

    Or you can use CSS to target images with the border-radius CSS property, setting it to a high value like 100px. You can see how this is done in the theme's stylesheet.

  5. Sexta Feira
    Member
    Posted 1 year ago #

    Thanks Caroline. I tried the gallery format with multiple pictures and only one of them appears as a circle, then below that the title, and then all of the pictures as regular squared images....i see what you mean with your post format test gallery page, but mine doesn't seem to appear like that. not sure what the problem is, i will see if i can give the css a go...

  6. Sexta Feira
    Member
    Posted 1 year ago #

    and one more question: where do i find the theme's stylesheet?

    thanks for your patience!!!

  7. Caroline Moore
    Member
    Theme Author

    Posted 1 year ago #

    The theme's stylesheet is style.css.

    And it sounds like only one picture is properly attached to the gallery formatted post. Try editing the post and re-uploading your images to it. Alternatively, you may be able to go to the Media tab in your Dashboard and attach previously uploaded images to the post in the "Attached to" column if they're not already attached to another post/page.

    You can read more about working with the Media library here:
    http://codex.wordpress.org/Media_Library_Screen

  8. Sexta Feira
    Member
    Posted 1 year ago #

    ok, bear with me please, this could be long and confusing :) let me just start by saying i'm glad you're so helpful and quick to respond and patient!

    so i'm still having some problems. It seems as though i've gotten the gallery format to work, (for some posts that is) but then all of a sudden, when i continued as I had been doing, only one of the pictures showed up as round, and actually before, they were all showing up as round and then underneath the title of the post as the standard rectangle...i deleted them from the post (so they essentially did not show up on the editing page) which deleted the rectangle pictures i didn't want, and somehow maintained the circular ones (even though the image doesn't appear on the edit post page..i'm not sure if that's correct or not, but i'll take it!)

    but now, as I said, all of a sudden they same problem i was having before started happening, and only one image shows up as a circle, and the rest as the standard rectangle. I have no idea what i did....

    i'm sending you the link (the address needs to be worked out, but that's a different story, don't worry, i've got someone helping me with that, it will not be the permanent link to the page), and actually, just now checking to make sure it works, i tried opening it with firefox (i'm using google chrome) and none of the images are circles, but oh well!

    let me know if you think of anything! thanks!

    http://dragon402.startdedicated.com/?p=103

  9. Sexta Feira
    Member
    Posted 1 year ago #

    and another thing i just realized....the circles in the gallery image are smaller than the ones on the home page...is there a way to make them the same size/bigger?

  10. Caroline Moore
    Member
    Theme Author

    Posted 1 year ago #

    This is because the rectangle images aren't part of the automatically generated gallery, they've been inserted into the content area. Delete them from the content area so they don't appear twice. You can read more about this here:
    http://wordpress.org/support/topic/posts-with-galleries-show-the-galleries-twice?replies=20

    It looks as though the second image is not properly attached to that post, so it doesn't show up as a circle in the gallery. The attachment process I talked about here should fix that:
    http://wordpress.org/support/topic/linking-to-different-posts-within-a-post?replies=10#post-4011397

    The circles in the gallery post format are intended to display smaller than the home page, since the content column is much narrower. You can override this in a child theme by copying content-gallery.php from the parent theme into your child theme and changing the number of columns on line 11. You may also need to change your settings under Settings -> Media and make the thumbnail images larger.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic