WordPress.org

Ready to get started?Download WordPress

Forums

Linking Slide to the URL (16 posts)

  1. marikakochi
    Member
    Posted 1 year ago #

    Hello,

    I started a web-site a week ago. http://georgianphotographers.com/

    There are a lot to add to it but currently I would like to solve the problem of the slider. I want to link the photos of the slider to the story but cant figure out how to do it.

    Im using the Adapt theme.

    When I upload a photo for the slider, it gives me an option to add slide description and Slide URL (the least one should in theory linkt the photo to the story no?)

    I copy and paste the URL in the box but it doesnt work.

    If you have an idea, I will be very grateful if u help me out!

    Thanks!

  2. jcwschor
    Member
    Posted 1 year ago #

    I have got exactly the same problem with the adapt theme. Description not showing and url not working. Difficult to get some kind of support on this (free) theme. Hope someone has a solution for this.

  3. tom_sawyer
    Member
    Posted 1 year ago #

    Hey guys! :) You know any comunity to get support of the wonderful Adapt Theme?

    My problem is that, but it don't worry me. What really worries me is that the highlight posts doesn't link anywhere!

    Have that happened to you?

  4. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Theme Forest provides a theme named Adapt...I am betting your FREE theme is a maligned copy of this commercial theme as I find no trusted sources for it as Free.

  5. fdneal
    Member
    Posted 1 year ago #

    Hello, all! I was having the same problem with the free adapt theme, and I found that changing a couple of lines in the "Slides.php" file fixed it:

    //            $slidelink = get_post_meta($post->ID, 'adapt_slides_url', TRUE);
                $slidelink = get_post_meta($post->ID, 'wpe_knowledge_slides_url', TRUE);
    //			$slide_description = get_post_meta($post->ID, 'adapt_slides_description', TRUE);
    			$slide_description = get_post_meta($post->ID, 'wpe_knowledge_slides_description', TRUE);

    I included the original (commented out) code, and the slightly tweaked code. Seems the variable was being fed the wrong values.
    I found the right values by studying the html source of the slide posting page.

    Anyhow, it worked for me, your mileage may vary...

    ~Dave!~

  6. AJClarke
    Member
    Posted 1 year ago #

    @fdneal - Hey, I'll have a look at the theme tonight and get it updated. I was unaware of the issue. Thanks for letting me know!

    ...I am working on some new free themes that I will keep updated constantly and try and provide bug support for. Hopefully in September with the WPExplorer re-design launch!

    @Seacoast Web Design - thanks for trolling buddy, but actually my free theme came out months before. Pretty sure the people from designer themes thought it would be a smart move to name their theme the same to get some automatic exposure.

  7. AJClarke
    Member
    Posted 1 year ago #

    Just updated...the issue was at one point I changed the name of the theme so in functions/meta/meta-usage.php the meta prefix was wpe_knowledge as you mentioned.

    I updated so all prefixes are wp_adapt - i also cleaned up the meta so it loads less junk and remove a couple debug errors.

    thanks fdneal for pointing this out!

  8. fdneal
    Member
    Posted 1 year ago #

    My pleasure! Glad I could help out. Thank YOU, AJ, for this terrific theme!

  9. thestealthyfox
    Member
    Posted 1 year ago #

    Does anyone know the coding to link the Highlights to a page instead of the Slider?

    It's the last thing I need to fix before the site is finished!

    Thanks in advance :)

  10. Rob49
    Member
    Posted 1 year ago #

    Hi AJClarke,

    First, thanks for a great theme! I am building a music site with Adapt and am almost finished.

    I am using v 1.1 and have the same issue as above where I cannot change the links in the gallery for portfolio entries. I am adding a image to run alongside an mp3 track but the link for the image won't change. I have got v 1.5 downloaded on my mac, but for some reason it won't replace 1.1 inside themes.

    As I have the files of 1.5, would it be possible to just cut/paste and swap in the updated files from 1.5 into my 1.1 theme? If so, could you let me know the file/files I need to update please? Or even just the ability to remove links in the portfolio altogether would be great.

    If you don't have the time no problem as I don't expect support for a free theme.

    Cheers AJ

    Rob

  11. Rob49
    Member
    Posted 1 year ago #

    Forgot to add I am adding the link inside the Gallery Metabox plugin which I added.

    Thanks

    Rob

  12. AJClarke
    Member
    Posted 1 year ago #

    Hey Rob,

    This isn't an actual issue with the theme. The default behavior of the theme is to open the single portfolio images in lightbox.

    The people above were mentioning the main homepage slider links not the portfolio galleries.

    If you want to open a custom URL for the links it's going to be a bit tricky. There isn't a built-in link option for images in WordPress so you'll need to add that extra field. Also you'll have to edit single-portfolio.php to echo your custom media field rather then a link to the full image size, and of course remove the lightbox class.

  13. Rob49
    Member
    Posted 1 year ago #

    Hey AJ,

    Your a star! :)

    As I didn't need the image to link to anything I removed a few lines of code in single-portfolio.php and that did the trick.

    Thanks again and all the best,

    Rob

  14. AJClarke
    Member
    Posted 1 year ago #

    Cool. Good luck with your project.

  15. piefruity
    Member
    Posted 1 year ago #

    hello,

    i need help in adapt theme slider:( . how will i change the motion of the slider . the main slider speed is very fast . i want to make the slides little bit slow..plz help me.

  16. phreakgirl
    Member
    Posted 12 months ago #

    It will most likely depend on what slider plugin, widget or theme, but you might try going to Appearance > Theme options > Slider Settings and see if there's a place to change it there, that's where mine is.

    slide transition speed (ms) = 500

    time between slide animation (ms) = 5000

    Also found it in /wp-content/themes/YourTheme/js/jquery.nivo.slider.pack.js: animSpeed:500,pauseTime:5000

Topic Closed

This topic has been closed to new replies.

About this Topic