WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Facebook: Advanced Sharing Optimization for All Social Websites
[resolved] Linked In number count positioned wrong (7 posts)

  1. sunkissmarc
    Member
    Posted 4 months ago #

    The Linked In number count appears below the Linked In share button instead of to the right of the share button. I have tried changing the order of the buttons but still get the same result for Linked In. Not sure if this is related to the size of the count (3 digit) because appears OK on other pages with less digits. Here is where you can see it:
    http://www.sunkissvillas.com
    Thanks in advance.

    https://wordpress.org/plugins/nextgen-facebook/

  2. JS Morisset
    Member
    Plugin Author

    Posted 4 months ago #

    You just need to adjust the width of that DIV. Check the Open Graph+ Style settings, under the Button Style tab. ;-)

    js.

  3. sunkissmarc
    Member
    Posted 4 months ago #

    Hi JS,
    I edited the "sharing-buttons.css" file, increasing the width for Linked In from 105px to 205px but it didn't change the problem.
    Here is the code:
    `.ngfb-buttons > div {
    display:inline-block;
    vertical-align:bottom;
    text-align:left;
    line-height:20px;
    width:200px;
    height:20px;
    padding:0;
    margin:2px;
    }

    /* Define specific widths for each button.
    * These defaults assume small button sizes with counters.
    */
    .ngfb-buttons div.facebook-button { width:149px; }
    .ngfb-buttons div.gplus-button { width:99px; }
    .ngfb-buttons div.gplusone-button { width:75px; }
    .ngfb-buttons div.twitter-button { width:89px; }
    .ngfb-buttons div.linkedin-button { width:205px; }
    .ngfb-buttons div.pinterest-button { width:78px; }
    .ngfb-buttons div.reddit-button { width:130px; }
    .ngfb-buttons div.managewp-button { width:100px; }
    .ngfb-buttons div.stumbleupon-button { width:84px; }
    .ngfb-buttons div.tumblr-button { width:85px; }

    I could use some direction here.
    Thanks,
    Mark

  4. JS Morisset
    Member
    Plugin Author

    Posted 4 months ago #

    That looks fine, but the .linkedin-button class still shows as 105px:

    .ngfb-buttons div.linkedin-button{width:105px}

    You can do a "view source" to check yourself.

    Are you running a full page cache? You may need to flush that cache.

    js.

  5. sunkissmarc
    Member
    Posted 4 months ago #

    I've changed it in the plugin editor to 150px but within the button style tab in the plugin it still shows 105px and is not editable in the free version.

  6. sunkissmarc
    Member
    Posted 4 months ago #

    Also, I cleared my cache completely with no change. I also checked it in another browser - no change.

  7. JS Morisset
    Member
    Plugin Author

    Posted 4 months ago #

    Oh, right, I forgot about that. :)

    You either need to modify the default CSS style, but as you say, that requires the Pro version, or you have to override the CSS style after it's been included in the header. I often use a plugin called the Lazyest Stylesheet for this -- it loads last and allows me to override the default style of various plugins and themes.

    Another alternative would be to uncheck the 'Use the Social Stylesheet' option and include your own CSS styles in whatever stylesheet you use (presumably the style.css file from a child theme).

    js.

Reply

You must log in to post.

About this Plugin

About this Topic