WordPress.org

Ready to get started?Download WordPress

Forums

Linke root to wordpress folder, now get 500 error on wp-admin (6 posts)

  1. Kpanlogo07
    Member
    Posted 1 year ago #

    Hi,
    I put my content on my website theme using WordPress through my web provider, GoDaddy.com, and I was working on connecting my domain, http://www.sipcreative.com, to my wordpress folder (sipcreative.com/wordpress) using the WordPress instructions. The instructions had me copy, not move, an index.php, web.config, and wp-config.php file from the ‘WordPress’ folder to my domain’s root folder called ‘html’. (I did not have a .htaccess file to move according to GoDaddy.) Then it had me change a line in my index.php file to… require(‘./wordpress/wp-blog-header.php’); so that it included the ‘/wordpress’ in it. This is what my file looks like now:
    ---------------------------------------
    <?php
    /**
    * Front to the WordPress application. This file doesn't do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    *
    * @package WordPress
    */

    /**
    * Tells WordPress to load the WordPress theme and output it.
    *
    * @var bool
    */
    define('WP_USE_THEMES', true);

    /** Loads the WordPress Environment and Template */
    require('./wordpress/wp-blog-header.php');

    ---------------------------------------

    So I did all that. Now my website works by going directly to my url (www.sipcreative.com) However, when I tried to go back to my WordPress admin, it doesn’t. I get this error, ”
    500 – Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed.” when I try to go to my WordPress admin login page http://sipcreative.com/wordpress/wp-admin/.

    Do you know what I did wrong? I'm assuming that the two are related since I have just been logged in not long before. GoDaddy's customer rep only said that I probably had to modify additional lines somewhere, but couldn’t tell me where or how…since he didn’t have access to my files or something. I tried looking through the WordPress documents, but I’m not sure what I’m reading. Please help.

    Once other thing to mention is that I did also upgraded/updated WordPress, via the dashboard, to the latest version (don't know what number) during that login session, but I don't know if it's related.

    Thanks in advance.

    UPDATE: When surfing through my website,I notice some picture links were broken... To see if it was really loading my website or just getting it from my browsing history, I cleared the history. Now my website doesn't work either. Text shows, but everything else is broken.

  2. Go Daddy
    Go Daddy Support
    Posted 1 year ago #

    From your description, I can't be sure exactly why there was a problem, but I didn't see you mention changing the "Site address" in the General settings. That might be the issue. If your core WordPress files are in a different folder than the URL you want people to use, the "WordPress address" is the location of the core files (for you, that's http://sipcreative.com/wordpress), and the "Site address" would be the URL people type to find your site (for you, http://sipcreative.com).

    If that was not the cause of the problem, there are other ways to accomplish this. I'm guessing that your ultimate goal is to simply have your site show up without needing the /wordpress folder in the URL. Visiting your site now, I see that only our temporary page is displaying which indicates that you don't have any important content in the root of your site which might conflict with your WordPress files. Of course, I can't be absolutely sure of this, but it's an educated guess without having direct access to your account (we won't discuss specifics of a customer's account without validating identity by phone or email).

    So, if putting the files in the root wouldn't disturb other efforts you've made with your hosting account, you could just move your WordPress files from the WordPress folder into the root. BEFORE doing this, you would need to first change the WordPress address and Site address in the General Settings so that they are both http://sipcreative.com - if you move the files files first, you won't be able to access the admin area in order to make that change later. Of course, you could just move the files back if you had to.

    Let us know if you make a change that gets things setup the way you need.

    I also wanted to suggest that you consider switching your operating system from Windows to Linux. Generally speaking, you'll see better performance for a WordPress site (or any PHP code) on Linux. If you want to make the switch, we have a help article that steps you through the process - http://x.co/switchos
    Note that you would need to disable and re-enable permalinks after the change, but everything else should be easy.

    Hope this all helps.

    Alon

  3. Kpanlogo07
    Member
    Posted 1 year ago #

    Hi, GoDaddy. Thanks for the reply.

    You are correct.I just want to be able to type http://www.sipcreative.com an see my wordpress website.

    I had changed the site address to http://sipcreative.com/ though I did not mention it.

    These are the wordpress instructions I used originally... http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    The section called "Using a pre-existing subdirectory install"

    I ended up having to undo what I did in order to get my WordPress to work again (500 error). I removed the index.php, web.config, and wp-config.php files from my root folder and changed the WordPress site address back to http://sipcreative.com/wordpress. So now I'm back to square one. I can access wordpress and see my website correctly on http://sipcreative.com/wordpress/. But not on http://www.sipcreative.com.

    Though I don't have an index file in my root, I do have some files (pdf, flash, etc) that I link to on occasion.

    I will try moving the WordPress files into my root folder. Do you know where the instructions on that are?

    I don't know what you mean by switching my operating system from Windows to Linux. I'm not that technically inclined.

  4. Kpanlogo07
    Member
    Posted 1 year ago #

    Well, I changed the WordPress and Site urls to http://sipcreative.com/

    I tried to move all the files in the /wordpress/ folder to my root folder using GoDaddy's FTP file manager, but it only moved the files and not the subfolders or their contents (gives me an error... did not perform task successfully). Since I couldn't move them all, I moved the stuff back into the wordpress folder.

    Since I changed the addresses, now WordPress admin and my website cannot be found. 404 (Page Not Found) Error

  5. Kpanlogo07
    Member
    Posted 1 year ago #

    Okay. Got access back to WP and my website with
    http://codex.wordpress.org/Changing_The_Site_URL

    Does anyone know good instructions on how to move my files to the root directory keeping in mind that I have Window operating system?

  6. Go Daddy
    Go Daddy Support
    Posted 1 year ago #

    To move WordPress from /wordpress to the root directory of your hosting account you will need to make a few changes. You will need to physically move the files in your hosting account to the root directory, which you can do using 3rd party FTP client or the File Manger in your hosting account: http://go.me/a9. I'm not sure what happened previously with you not being able to move subfolders.

    You will then need to modify the domain name for the blog from sipcreative.com/wordpress to sipcreative.com within the WordPress configuration file and update the database to reflect this as well. The article http://go.me/aA describes how to update the database. It also refers to the link you mentioned earlier for how to change the site URL for your blog.

    http://codex.wordpress.org/Changing_The_Site_URL

    Hopefully this info will help.

    ^Cj

Topic Closed

This topic has been closed to new replies.

About this Topic