WordPress.org

Ready to get started?Download WordPress

Forums

SSL Insecure Content Fixer
[resolved] Link to External Site Getting forced Https (6 posts)

  1. criana
    Member
    Posted 5 months ago #

    Hi,
    I have a link in the footer of my site going to an external site, and while I have the link coded to be http:// it's getting rewritten to https:// when displayed on the site. Is there a way to exclude this?

    Thanks

    http://wordpress.org/plugins/ssl-insecure-content-fixer/

  2. webaware
    Member
    Plugin Author

    Posted 5 months ago #

    G'day Criana,

    First, can you provide a link to your site please? Hard to diagnose without looking at the site.

    Second, how is the link getting into the footer? e.g. menu link, widget, theme settings, code in footer.php, ...

    cheers,
    Ross

  3. criana
    Member
    Posted 5 months ago #

    Hey Ross,
    Sorry about that, it's BBB site. The link in question is the one for "Website Supported by..."

    The link is being placed via standard markup in the Theme Options > Footer Text area of an Admin panel.

    Thanks for your assistance,
    Diana

  4. webaware
    Member
    Plugin Author

    Posted 5 months ago #

    Do you perhaps have a protocol-free link to that website, i.e. just // instead of http://?

    Alternatively, can you confirm that it's the SSL Insecure Content Fixer plugin that's changing the URL? I don't see how it can be, might need to look harder but please confirm first.

    Also, your site is still loading a font from Google Webfonts over HTTP, look at the CSS files in your theme for an @import statement.

    cheers,
    Ross

  5. criana
    Member
    Posted 5 months ago #

    Hi Ross,
    My apologies, disabling the plugin did not resolve the issue, now i have to track down where in WP or the hosting Admin it's forcing every single thing to be in HTTPS.

    Thanks for the find on the Google Webfonts.

    Sorry for the inconvenience and thanks for the support,

    Diana

  6. webaware
    Member
    Plugin Author

    Posted 5 months ago #

    G'day Diana,

    It'll be WooCommerce. Try deactivating that plugin to confirm, and contact their support if it is them. BTW, you probably don't need SSL Insecure Content Fixer if you're using WooCommerce, because that plugin does much the same thing as mine (some more, some less).

    cheers,
    Ross

Reply

You must log in to post.

About this Plugin

About this Topic