WordPress.org

Ready to get started?Download WordPress

Forums

Byline
[resolved] Link to author's name doesn't work (6 posts)

  1. DivaVocals
    Member
    Posted 1 year ago #

    Goes to a page not found page.. If I can't figure this out I'll be back to the drawing board looking for another plugin like this..

    http://wordpress.org/plugins/byline/

  2. DivaVocals
    Member
    Posted 1 year ago #

    Looks like other plugins in this class have some of the same issues.. I looked at Co Authors Plus and couldn't get that fully working either for similar reasons.. (Similar in that this plugin isn't a WHOLE solution either unless you can figure out the right function you need to add to your theme to get it to work correctly)

    The Bylines plugin changes the name just fine, but the link to the author page just does not work which is why I can't use this either..
    http://mysite.com/byline/author slug]/

    I thought a plugin would make this easy, but I think I would just rather just use a custom function to handle the author name display and author page link and be done with it.. Here's what I did..

    To display the guest authors name in the guest posts, I've added a function to my theme's functions.php file so that using a custom field, my guest authors name will appear in place of the name of WordPress user who posted the article..

    This same function does something similar with the author link. I enter the author page link in a custom field. Since the Co-Authors Plus plugin creates a WORKING author page for my guest authors, I can use that as the author link URL in the custom field.

    So all together this is how this will work for me:
    I use Co-Authors Plus to create a guest author profile.. I grab the slug from my author profile. The slug will make up the author page URL (http://yoursite.com/author/author slug]/)

    Now I create my post, add the author's name and the author page URL to my custom fields, then change the post author to the author I added using Co-Authors Plus (so that this post will appear as a part of this authors postings), and it all works as I need it to..

    Yes I KNOW that this is more work. Had I been able to figure out how to configure Co-Authors Plus, or had the Bylines plugin worked, I wouldn't need to do this.. Soooooooo... For now this is a usable workaround..

    Reply

  3. rtainter
    Member
    Posted 10 months ago #

    I think you just have to refresh your .htaccess (Done through settings>>permalinks>>save). This usually has to be done whenever a custom taxonomy is added.

  4. rtainter
    Member
    Posted 9 months ago #

    should have said rewrite_rules options instead of .htaccess (Same process though)

  5. mattdu
    Member
    Plugin Author

    Posted 8 months ago #

    Flushing rewrite rules does the trick. I will add that to the next update to the plugin. You can force a rewrite-flush by visiting the Settings/Permalink page in your WP admin.

  6. Dan Knauss
    Member
    Posted 6 months ago #

    Shoot, I always forget about flushing transients when something goes wrong like this. It's definitely a barrier to people trying out this plugin, but it shouldn't be -- this is the best simple solution available.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.