WordPress.org

Ready to get started?Download WordPress

Forums

Link Not Working Properly (11 posts)

  1. Will Guy
    Member
    Posted 1 year ago #

    As you can see at http://iheater.info/, when you click on the link at the top saying "iHeater – Everything You Need To Know Is Right Here", instead of going to a page for that blog post it goes to a page that says "Not Found. Sorry, but you are looking for something that isn't here"

    Could someone please direct me on how to fix this.

  2. Phil Erb
    Member
    Posted 1 year ago #

    When you look at Posts in the Dashboard, do you see the post you are looking for? If so, toward the top of the post editor page, it should list the post's perms link - what is this value?

  3. Will Guy
    Member
    Posted 1 year ago #

    I don't know what you mean by "What is this value".

    If you mean the permalink, it is http://iheater.info/iheater/.

  4. When you are in the admin and click view post, do you also get the page not found?

    If not, maybe try resetting the permalinks? Just switch them to default and then back to what you want them to be. Perhaps something funky is happening.

  5. Phil Erb
    Member
    Posted 1 year ago #

    I apologize for the confusion - that is exactly what I meant.

    For clarification - what should this link be going to? Does http://iheater.info/iheater/ contain different information than the homepage, or is that the page that you have set as the custom homepage? It seems like that link is the title of the homepage, that's why I want to verify.

  6. Phil Erb
    Member
    Posted 1 year ago #

    I didn't see Christine's post before I hit submit - I definitely agree.

    I was thinking that if the http://iheater.info/iheater page was the page that you set as the custom homepage, but the title link was still trying to refer to the old permalink (which would normally get changed to http://iheater.info/ when you set that page as the homepage), then that might be causing an issue.

  7. Will Guy
    Member
    Posted 1 year ago #

    I have that post set as the top message on the homepage with the WP Sticky plugin. It seems like that link should go to the individual page for the blog post as well though, instead of going to the "Not Found" page.

  8. Phil Erb
    Member
    Posted 1 year ago #

    Agreed - when things are working properly, going to the permalink for a page/post should bring up that page/post and not a "not found" page.

    Two things to try:

    1) Reset the permalinks, as Christine suggested above.
    2) Disable the WP Sticky plugin and try to go to http://iheater.info/iheater/ - does this work?

    Also, verify that the iheater post has the status Published. You can check this by viewing the post in the Dashboard and looking in the top-right widget on the post editor screen. If it isn't published, it wouldn't be available for viewing, which would cause the "not found" page to be displayed. I wouldn't think that the WP Sticky plugin would show it if it weren't published, but I don't have experience with that specific plugin either.

  9. Will Guy
    Member
    Posted 1 year ago #

    I tried messing around with the permalink. That didn't help with the problem.

    Thanks anyway though.

  10. Will Guy
    Member
    Posted 1 year ago #

    Tried disabling the WP Sticky plugin. That didn't help either.

  11. Phil Erb
    Member
    Posted 1 year ago #

    Will - Any resolution on this or further information that might help in troubleshooting?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.