WordPress.org

Ready to get started?Download WordPress

Forums

Link- Library images broken (5 posts)

  1. designCannon
    Member
    Posted 3 years ago #

    I'm using the latest version of Link-Library. The auto-generated thumbnails are working just fine, but if I manually upload images the images are broken. Even though the manually uploaded images are going into the same folder (wp-content/uploads/link-library-images) as the auto-generated thumbnails, Link-Library is looking for them in the wrong place (wp-content/uploads/uploads/link-library-images).

    Why the double-up on "uploads/"? How can I stop it from doing that?

  2. drperil
    Member
    Posted 3 years ago #

    I am also having this problem.
    The Image is uploaded correctly to wp-content/uploads/link-library-images/
    but the image link that's included by link library (that is, the image shown in the link list on the page) is broken. When you "open this image in another tab" in Chrome you get url.com/wp-content/uploads/uploads/link-library-images/**.jpg

    So, not sure what's going on there, but for some reason LL is sticking an extra "uploads" dir into the URL. Any help would be much appreciated.

  3. drperil
    Member
    Posted 3 years ago #

    Thoughts, anyone?
    This is kill'n me :(

    For a temp fix in the Advanced area you can edit the path to the image... extra step but I suppose it works.

  4. TheFatherMind
    Member
    Posted 3 years ago #

    I created a symbolic link in my uploads folder to its self...
    ln -s ../uploads uploads
    But even after that it was looking at the wrong image for some reason and now I am having odd space issues on the display of text.

  5. Yannick Lefebvre
    Member
    Posted 3 years ago #

    A temporary fix would be to change line 3283 from:

    $file_path = $uploads['baseurl'] . "/uploads/link-library-images/" . $link_id . ".jpg";

    to:

    $file_path = $uploads['baseurl'] . "/link-library-images/" . $link_id . ".jpg";

    That should do the trick. I will roll this change in the next version that I am currently working on but where I'm only part ways through the development.

Topic Closed

This topic has been closed to new replies.

About this Topic