WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] link issue (8 posts)

  1. bluscale
    Member
    Posted 6 years ago #

    noob q. fresh install and some things aren't working. if i click on say uncategorized, it takes me to a directory index with the url http://localhost/wordpress/?cat=5. from what i've been reading, it's a permalink issue. can someone confirm or redirect me?

  2. CyberCobre
    Member
    Posted 6 years ago #

    Um...localhost? That's wrong. Did you do this install manually? If so, your config.php file needs some work. It should look like this:

    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/ **/

    // ** MySQL settings ** //
    define('WP_CACHE', true); //Added by WP-Cache Manager
    define('DB_NAME', 'yourdatabasename'); // The name of the database
    define('DB_USER', 'yourdatabaseusername'); // Your MySQL username
    define('DB_PASSWORD', 'yourdatabasepassword'); // ...and password
    define('DB_HOST', 'yourdatabasehostname'); // ...and the server MySQL is running on

    // Change the prefix if you want to have multiple blogs in a single database.

    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;

    define('ABSPATH', dirname(__FILE__).'/');

    // Get everything else
    require_once(ABSPATH.'wp-settings.php');
    ?>

    If it doesn't look like that, change the places where I typed in yourblahblahblah to your correct parameters.

    MAKE SURE YOU DOWNLOAD AND UPLOAD IN FORCED ASCII

  3. bluscale
    Member
    Posted 6 years ago #

    Oh, I should have mentioned that I'm only doing this for fun, I said localhost so not to give out my IP address.

    I made all those changes as necessary during installation. My posts are being saved and I am able to publish but my links in index.php aren't working.

  4. bluscale
    Member
    Posted 6 years ago #

    To be honest, I've fulfilled my needs using wordpress. I can add and edit blogs and show them at a custom homepage. But all the other features aren't working and I'd like to try them out.

    All my links don't go to a page, they do to the root directory where I placed wordpress. My URL's all say http:...root/?variable=number as opposed to root/some page?variable=number. I'm I just way off base here?

  5. bluscale
    Member
    Posted 6 years ago #

    Thanks for the help guys! //sarcasm

  6. bluscale
    Member
    Posted 6 years ago #

    So, my main issue hasn't been resolved. When I say my links don't work, I mean they're not functioning. A category is supposed to bring up all the post listed under it right? Well, I don't get that. The URL looks fine and I can add posts and even edit them but for some reason, category links don't produce anything besides a view of the root directory.

  7. bluscale
    Member
    Posted 6 years ago #

    I guess I just had to set up permalinks. Thought it was optional.

  8. shadow
    Member
    Posted 6 years ago #

    Without seeing your site and having some understanding f what it is doing, it is difficult to help. We could take a lot of guesses, but that makes it pointless too.

Topic Closed

This topic has been closed to new replies.

About this Topic