WordPress.org

Ready to get started?Download WordPress

Forums

Meteor Slides
[resolved] link in slides doesn't work (12 posts)

  1. buseca
    Member
    Posted 1 year ago #

    Hi everybody,
    I just noticed that the links in the slides don't work: I inserted an http://.... link in the slide link input, but from the inspector i see there is no tag in the slideshow.

    I never tried it before so i don't know if it's a recent bug or if it was already like that.

    Someone with the same problem?
    Tnx

    Ruggero

    http://wordpress.org/extend/plugins/meteor-slides/

  2. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    The link didn't post correctly, can you post a link to the site you're working on?

  3. buseca
    Member
    Posted 1 year ago #

    the website is http://www.arsrovagnate.it
    there is only one slide, in the homepage.

  4. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    Try updating to Meteor Slides 1.5.1 which has better support for single slide slideshows. Are you using a custom slideshow template or anything?

  5. PinkishHue
    Member
    Posted 1 year ago #

    I am having the same problem I think. I have added URL's for the slides to link to but they are instead linking to:

    website.co.uk/?slide=slide-name

    Which just gives a 404 page not found

    Any suggestions?

    (I am using 1.5.1)

    Edited to add:

    I just ran the W3 HTML Validator on the page and realised the slides are being given multiple anchor tags, the first anchor which I have set on the settings page, then within that the default anchor, like so:

    <a href="http://mywebsite.co.uk/category/mycategory/" title="ATitle"><a href="http://mywebsite.co.uk/?slide=name" title="ATitle"><img width="980" height="283" src="http://mywebsite.co.uk/wp-content/uploads/2012/12/myimage1.jpg" class="attachment-featured-slide wp-post-image" alt="ATitle" title="ATitle" /></a></a>

    I am going to delete the slides and add them again, see if that fixes the problem.

  6. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    This is because your theme is linking the blog post featured images incorrectly. It is filtering all featured images, including the slide images, and adding the post permalink to them.

    Instead it should specifically add links to the featured images when they are added in the template files. What theme are you using, can you post a link?

  7. buseca
    Member
    Posted 1 year ago #

    I resolved adding more slides in the slideshow.. now the link works.

  8. Josh Leuze
    Member
    Plugin Author

    Posted 1 year ago #

    @buseca Great, that's good news.

  9. Tackleberry
    Member
    Posted 3 months ago #

    Hello Josh,

    i have the same Problems with the links on slides.
    It works with the theme "Twenty Twelve", but not with the theme "tempera".

    With the theme "tempera" i only see links like this:

    ?slide=wein-sektgut-barth

    "wein-sektgut-barth" is the slug name of the slide ...

    Here is my new side on the test-server:
    http://rwu.de/tobso/domains/de-webdesign-rheingau/

    You can see the slideshow under "Referenzen".

    Thanks a lot!

  10. Josh Leuze
    Member
    Plugin Author

    Posted 3 months ago #

    @Tackleberry The Tempera theme is incorrectly filtering all featured images and adding a link to the image's post permalink to them, including the slide images.

    It should either check the post type and only do this for blog posts, or it should be removed completely and the post thumbnails in the theme should be updated with links directly rather than via a filter.

    If you comment out line 334 of the includes/theme-loop.php file the slide links should work correctly:

    //if ($tempera_fpost=='Enable' && $tempera_fpostlink) add_filter( 'post_thumbnail_html', 'tempera_thumbnail_link', 10, 3 );
  11. Tackleberry
    Member
    Posted 3 months ago #

    Hi Josh,

    you are my hero!
    It works!

    Thanks a lot!

  12. Josh Leuze
    Member
    Plugin Author

    Posted 3 months ago #

    You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic