WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
link all variations not working anymore (12 posts)

  1. reto.kuepfer
    Member
    Posted 2 months ago #

    Hi
    Since i updated to 2.1.9., the "link all variations" funktion is not working anymore.
    It's just adding "0 variations"
    Tested it on 2 different sites.
    It is also not a conflict with other plugins.

    https://wordpress.org/plugins/woocommerce/

  2. netweavers
    Member
    Posted 2 months ago #

    I confirm that 'link all variations' does not work in 2.1.9.
    Please fix it guys.

  3. jrvolpato
    Member
    Posted 2 months ago #

    Same for me. Just stopped working in 2.1.9.

  4. lstephan
    Member
    Posted 2 months ago #

    Hi,

    I ve got the same problem. When i m linking variations server is waiting for a very long time and nothing happens.

    Any idea?

  5. lstephan
    Member
    Posted 2 months ago #

    Was it working with 2.1.8 version of woocommerce?

    So is it possible to go back to 2.1.8 without any pb and how?

  6. lstephan
    Member
    Posted 2 months ago #

    Went back to 2.1.8 version.

    Linking variation ok ...

  7. Roy Ho
    Member
    Posted 2 months ago #

    Yes some updates from the last commit broke this for menu order/custom ordering. We'll push out a update real soon.

    Meanwhile, you can get around this by going to your attribute change the ordering from custom ordering to name. Then go to your variations and click link all and this time it should work. After linking them, then you can probably switch your attributes back to custom ordering.

    Again this is just a work around for now.

  8. zdenekca
    Member
    Posted 2 months ago #

    This is a critical issue for many people (who wants to enter 24 variations for 30 products manually?). I am surprised you didn't fix this immediately. I have spent 30 min with this issue and luckily I found your temporary solution.

    Cheers

  9. mediopirzel
    Member
    Posted 2 months ago #

    I agree this is a critical issue.
    Can you explain step by step how to temporary link to variations?
    I don't understand this step:

    Meanwhile, you can get around this by going to your attribute change the ordering from custom ordering to name

  10. lorro
    Member
    Posted 2 months ago #

    Admin page / Products menu / Attributes sub-menu / Default sort order dropdown - this defaults to "custom ordering" but change it to "name".

  11. mediopirzel
    Member
    Posted 2 months ago #

    It works, thank you.
    I didn't know attributes has order options.

  12. fortiz9
    Member
    Posted 2 months ago #

    This was not enough in my case, but it gave me a good clue: in addition to the recommended procedure, I had to edit the attribute internally (color) itself, from "custom ordering" to "name".
    Now it works, thanks.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.