WordPress.org

Ready to get started?Download WordPress

Forums

Line Error is killing! Somebody please. (8 posts)

  1. d0cpaul
    Member
    Posted 4 years ago #

    So I was messing with the wp-config.php file and I copied all the codes before re-uploading.. Now i get this error on my site..

    Fatal error: Call to undefined function wp() in /home/content/l/o/a/loansafe/html/blog/wp-blog-header.php on line 14

    here's my site:

    PLEASE HELP

  2. esmi
    Forum Moderator
    Posted 4 years ago #

  3. UserName9
    Member
    Posted 4 years ago #

    Did you change anything in wp-config file? do u have the backup?
    try putting it back on, because your wp-config file is missing one of the lines.

  4. d0cpaul
    Member
    Posted 4 years ago #

    Yeah I tried putting in this new code but it didn't work so I took it out and I copied the original code to another document and when i pasted it back i got that error.

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    I took it out and I copied the original code to another document and when i pasted it back

    What did you use for the copy'n'paste? If it was anything other than a plain text editor, you may have introduced some non-standard characters into the code.

    Try copying the contents of the entire file into a text editor (such as Notepad) emptying the wp-config.php and then pasting the contents from the text editor back in again from your wp-config.php file. Make sure that you do not leave any spaces or blank lines before the opening <?php or after the closing ?> tags. Place your cursor after the '?>` tag, then press and and hold the Delete key for 15 seconds to make absolutely sure that are no trailing spaces.

  6. d0cpaul
    Member
    Posted 4 years ago #

    Yes I know about the space and I there is not any before <?php or after closing ?>

    Note pad is all I used.

  7. whooami
    Member
    Posted 4 years ago #

    whatever you did, you did wrong. So put back working backups of the file(s) you changed.

  8. d0cpaul
    Member
    Posted 4 years ago #

    I did but its still not working...

    Can you tell me if i there is something wrong with the code?

    <?php
    // ** MySQL settings **//
    define('DB_NAME', '************************');

    /* The name of the database **/
    define('DB_USER', '*************************');

    /* Your MySQL username */
    define('DB_PASSWORD', '*********************');

    /* ...and password */
    define('DB_HOST', '*************************');

    /* 99% chance you won't need to change this value */
    define('DB_CHARSET', 'utf8');

    define('DB_COLLATE', '');

    /* Change each KEY to a different unique phrase. You won't have to remember the phrases later, */
    /* so make them long and complicated. You can visit http://api.wordpress.org/secret-key/1.1/ */
    /* to get keys generated for you, or just make something up. Each key should have a different phrase. **/
    define('AUTH_KEY', 'put your unique phrase here');

    /* Change this to a unique phrase.*/
    define('SECURE_AUTH_KEY', 'put your unique phrase here');
    /* Change this to a unique phrase. */

    define('LOGGED_IN_KEY', 'put your unique phrase here');

    /* Change this to a unique phrase. */
    // You can have multiple installations in one database if you give each a unique prefix$table_prefix = 'wp_';
    // Only numbers, letters, and underscores please!
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');/* That's all, stop editing! Happy blogging. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    require_once(ABSPATH . 'wp-settings.php');?>

Topic Closed

This topic has been closed to new replies.

About this Topic