WordPress.org

Ready to get started?Download WordPress

Forums

Line Breaks in comments (17 posts)

  1. superultra
    Member
    Posted 9 years ago #

    migrating from MT and notice that line breaks show when editing comments, but in the actual blog all line breaks are removed. any ideas?

  2. usafdcc
    Member
    Posted 9 years ago #

    Can we get your URL so we can see what it looks like?

  3. superultra
    Member
    Posted 9 years ago #

    sure. I also noticed it's on the blog I set up for my wife:
    http://www.beelerspace.com
    http://www.popularstranger.com

  4. superultra
    Member
    Posted 9 years ago #

    Anyone have a similar problem (and hopefully a solution)?

  5. davidprince
    Member
    Posted 9 years ago #

    I have a similar problem. Double line breaks (comment entry and previewing) are converted to single line breaks when the comment is posted. This little "quirk" is actually quite annoying if some one leaves a long comment because everything runs into each other. It makes them hard to read.

  6. superultra
    Member
    Posted 9 years ago #

    Agreed. I keep thinking that maybe line breaks are considered bad html by WordPress? And if you view the comment in the backend it looks it should. It's in building the page that the line breaks disappear. Quite annoying.

  7. superultra
    Member
    Posted 9 years ago #

    I'm wondering if this is a problem in the code somewhere. Has anyone had any success hacking the comment code so that it includes line breaks as it should?

  8. superultra
    Member
    Posted 9 years ago #

    Still looking for a solution to this. I can't be alone since it's occuring on two blogs on two web servers. Anyone?
    Thanks in advance. =)

  9. superultra
    Member
    Posted 9 years ago #

    So...um...yeah...about those line breaks.
    -cough-

  10. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I just test commented, and I've not seen that behaviour on any other WP blog that I have used.
    Have you modified any of the files in /wp-includes ?

  11. superultra
    Member
    Posted 9 years ago #

    Hmm, I did a little on my wife's blog (popularstranger) but the beelerspace install was a clean one. Weird huh. Thanks for checking it out though Podz.

  12. superultra
    Member
    Posted 9 years ago #

    I tried using the default templates and it exhibits the same behavior. Weird, huh.

  13. Mark (podz)
    Support Maven
    Posted 9 years ago #

    It really does look like your comments 'engine' is breaking it.
    If I view source on some comments on my site, they are contained as part of a list, and wrapped in tags.
    If I view source on your site, then are contained in a table and wrapped in a div.
    My 'shot in the dark' next was going to be that there was something wrong in the file 'kses.php' (due to uploading maybe) but now it looks odder.

  14. superultra
    Member
    Posted 9 years ago #

    Yeah my html is messy (and uses tables). But it should be fixed, then, if I use the default template and it's not. It has to be somewhere else.
    The thing that's driving me crazy is that it _has_ to be something I'm doing, as it has occured on both mine and my wife's blog (which i set up). Grr (to me).

  15. superultra
    Member
    Posted 9 years ago #

    Ah ha. The spoiler plugin broke my comments, for one some strange reason. Disabled it and it works. I'll comb the code to figure out why it doesn't work.

  16. idban
    Member
    Posted 9 years ago #

  17. jemimap
    Member
    Posted 9 years ago #

    I had the same problem, but not from the spoiler-fix plugin. I'd changed the wpautop function to eliminate stray linebreaks in my imported blogger entries, and that had the unintentional effect on my comments. I blogged about the problem and my fix here: http://jemimap.ficml.org/wordpress/2004/11/14/wp-line-breaks-in-comments/.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.