WordPress.org

Ready to get started?Download WordPress

Forums

TablePress
[resolved] line break (6 posts)

  1. Schuko
    Member
    Posted 1 year ago #

    Hi Tobias,

    I am currently building a webiste for our company. One part of this is a simple planning area, which I want to set up with Tablepress.

    My Problem is the following: When I type in a little more information in one cell, the lines donĀ“t break. Therefore the table is extremly wide.

    Is there some way to fix this?

    I really tried to find some already resolved questions on this but did not succeed.

    Thanks for your help in advance,
    Regards

    http://wordpress.org/extend/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for your post.

    I'm not really sure what you mean here. Can you please post a link to the page with the table?
    Also, why don't you add manual line breaks?

    Regards,
    Tobias

  3. Schuko
    Member
    Posted 1 year ago #

    Hi,

    well it seems it was my own stupidity getting in the way there :-)

    Anyhow, there is one more thing:

    Can I show the borders of the columns to make it nicer to look at and have a better overview?

    Here is the link: http://www.vacomat.de/cad/

    Thank you :)

  4. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for the link!
    That helped to actually identify an issue on your page. The table Shortcode seems to be wrapped in extra and unnecessary HTML code. To remove that, please go to the editor where you inserted the Shortcode for the table, and switch from the "Visual" editor to the "Text" editor there.
    You should seem something like

    <pre><strong>[table id=3 /]</strong></pre>

    Remove the extra HTML code there, so that this becomes

    [table id=3 /]

    This will already fix the problem with the line breaks, and make the table use the correct fonts.
    You should then also not need the extra CSS that you are using now for the width, so I suggest that you remove that as a test.

    After that, please add this to the "Custom CSS" textarea on the "Plugin Options" screen of TablePress, to fix the spacing in the table cells:

    .tablepress td {
      padding: 8px !important;
    }

    Finally, if you really want borders for all cells, please add this:

    .tablepress-id-3 th,
    .tablepress-id-3 td {
        border: 1px solid #dddddd;
    }

    Regards,
    Tobias

  5. Schuko
    Member
    Posted 1 year ago #

    Wow, thank you so so much!

    It looks just the way I want it to.

  6. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    sure, no problem! You are very welcome!
    Good to hear that this helped :-)

    Best wishes,
    Tobias

    P.S.: In case you haven't, please rate TablePress here in the plugin directory. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags