WordPress.org

Ready to get started?Download WordPress

Forums

Tweet Blender
Limited functionality outside of WordPress directory (3 posts)

  1. kfdesign
    Member
    Posted 2 years ago #

    First off, I love Tweet Blender. I want to use it outside of my WordPress directory (at site root level) but I'm having trouble.

    Here's TB running perfectly with some code placed straight into /wordpress/sidebar.php (using theme editor not the widget tool):

    http://www.recordingartistsproject.com/wordpress/

    Here's the code:

    <?php
    tweet_blender_widget(array(
        'unique_div_id' => 'sidebarphp',
        'sources' => '@hypebot,@musicthinktank',
        'refresh_rate' => 60,
        'tweets_num' => 4,
    ));
    ?>

    What I'm trying to do now is put TB on pages at the site's root, but when I copy the exact same code in, TB doesn't appear: http://www.recordingartistsproject.com/index-tb.php

    It should be in the bottom middle column above Blog Topics (wp_list_categories).

    I CAN get TB to work at site root level, but only by limiting myself to a single hashtag or @username as the source. Here's an example of the same code as before, but with only one of those @usernames as the source:

    http://www.recordingartistsproject.com/index-tb-mtt.php

    Any of the following source values make TB disappear: more than one @username, a single @username/list, a single keyword (without a # or an @ before it). Also, TB is recognizing certain settings (like General>Links) but not others (Filters).

    I'm bringing in the /wordpress/ content to the root by adding this to the header of index.php:

    <?php
    // Include WordPress
    define('WP_USE_THEMES', false);
    require('./wordpress/wp-blog-header.php');
    ?>

    Have you seen anything like this? Any ideas?

    As a workaround, I can also stack two different Tweet Blenders on top of each other, each with different single @username as the source, but if nothing else I would like to get the Filters working so I can hide @ mentions.

    I've tried refreshing the cache as you recommended to another user (disabling caching, saving settings, reenabling caching, then saving settings again). I've also tried enabling the search API but it is currently off.

    Thanks!

  2. kfdesign
    Member
    Posted 2 years ago #

    Sorry, I had to change the /wordpress/ directory to /blog/ and forgot to change these links to reflect that. So here's the perfectly working TB link again:

    http://www.recordingartistsproject.com/blog/

    And the other two links above should be functioning again now.

  3. kfdesign
    Member
    Posted 2 years ago #

    I'm going to have to disable the show tweet author option (which works) because the site is about to go live, but if you can still solve it or if you think of anything though, please let me know. I'd love to use this on future projects.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic