WordPress.org

Ready to get started?Download WordPress

Forums

Lightword Theme "No Sidebar" issue (20 posts)

  1. Tosyk
    Member
    Posted 3 years ago #

    When i'm choosing on some pages "No sidebar" option all widgets hiding, but place for them is still on the right. In the previous version of Lightword Theme there is no problem like this, sidebar is hiding and all my gallery's pictures using full page.

    See my gallery issue:
    http://cg.forexperts.ru/gallery/

    Please help. I like Lightword theme, but this problem push me to change theme to something else, but i really don't want it.

  2. Karlos
    Member
    Posted 3 years ago #

    Same here, it seems we can't add any widgets to the sidebar as it wipes the existing 'sidebar' widgets. I'm not sure how this is setup...

  3. alchymyth
    Forum Moderator
    Posted 3 years ago #

    @Karlos

    different issue;

    what you describe is kind of standard to dynamic sidebars of most themes - i.e. it is programmed this way.

    when you drag the first widget into the sidebar area, the pre-existing default spaceholder 'widgets' dissappear.

    if you liked them, you need to drag the same widgets into the sidebar again

  4. Karlos
    Member
    Posted 3 years ago #

    Oh! of course, thanks for that.

  5. brownbair
    Member
    Posted 3 years ago #

    @Tosyk

    I see by your link that you were able to resolve this issue. Could you please let me know how because I have the same problem. I have one page (http://brownbair.com/wp/) that I would like to have no sidebar, and the rest are fine as they are. However, when I choose the "No Sidebar" option from the drop-down menu of the page editor, it does indeed get rid of the sidebar content, it just doesn't seem to be calling the new stylesheet that defines a single page layout.

    Please let me know if anyone can help me with this issue.

    Thanks so much!

    -AB

  6. Tosyk
    Member
    Posted 3 years ago #

    brownbair
    sorry, but it's error in lightwood code (php i think), no one help me here, so i ask my admin to resolving this, and he made it

  7. selarsen
    Member
    Posted 3 years ago #

    @Tosyk: can you please share your "single-page-template.php" file with us?

  8. selarsen
    Member
    Posted 3 years ago #

    @Tosyk: and also your "single-page-template.css" file?

  9. brownbair
    Member
    Posted 3 years ago #

    @selarsen

    All I did to fix the problem was paste the following:

    <link rel='stylesheet' id='lightword_stylesheet_single-page-template-css' href='http://YOURPAGE.com/wp-content/themes/lightword/single-page-template.css?ver=2.0.0.6' type='text/css' media='all' />

    after this:

    <?php wp_head(); ?>

    in the single-page-template.php file. That cleared it all up, I'm pretty sure. But let me know if you have any more trouble and I'll look to see if I did anything else to fix the problem. =)

    -AB
    http://brownbair.com

  10. selarsen
    Member
    Posted 3 years ago #

    @brownbair: thanks for your help, that removed the sidebar as i wanted to! only one issue: the single page template messes up my menu buttons at the top...

    link:
    http://selarsen.com/

    in my "tjenester" page, or any other page where i use normal template with sidebar, the buttons works as supposed. link:
    http://selarsen.com/tjenester/

    this is happening with the new w3-menu option both on and off, it makes no difference for the main page using the single page template...

  11. selarsen
    Member
    Posted 3 years ago #

    any suggestions anyone??

  12. selarsen
    Member
    Posted 3 years ago #

    okay, so i updated to 2.0.0.7 from github https://github.com/andreiluca/LightWord after talking to andrei luca on twitter.

    i had to add the code from brownbair (see post above) to remove the sidebar in single page template. that did work.

    the menu buttons are still not working properly, and after the update the "home" button does appear and cannot be removed. **this only applies to single page template, pages using default template works as they should**

    I really need help with this one. I have tried w3-options both on and off, reinstalling both wordpress and lightword, nothing works. am i the only one with this problem?

  13. dgw
    Member
    Posted 3 years ago #

    selarsen, I'd like to try fixing this issue. If you could please make an export of your database and post it somewhere, then send me a link to that backup file in a message through http://technobabbl.es/contact/, I'll get that data into my test site and hack on it when I get some free time.

    Note that the version of 2.0.0.7 you have isn't final, so depending on how you updated LightWord this time you might have to change your method and do this instead. (WP has some good safeguards, but sometimes they just get in the way.)

    Please do remind me of both issues discussed here (the sidebar and the menu failure), since it might be a few weeks before I get to this project. Also, it couldn't hurt to have screenshots of a page that works and a page that's broken, for my reference while I'm trying to fix it.

    Thanks for your help. I'm sure this one will be fixed in the end. :)

  14. brownbair
    Member
    Posted 3 years ago #

    @ selarsen

    I totally had this problem as well, but for the life of me I can't think of what I did to fix it. If I have time today, I'll go through my files and see if anything sticks out as a possible solution.

    Sorry I can't be of more help at the moment.

    Best of luck!

    -AB
    http://brownbair.com

  15. dgw
    Member
    Posted 3 years ago #

    @brownbair:

    If you do figure it out, I'd love to hear about it. Your fix could make it into a LightWord update. Please do hit me up if you have any information that might be helpful.

    Thanks!

  16. brownbair
    Member
    Posted 3 years ago #

    @selarsen

    When you created your menu bar, you gave it a title, correct? You should have done that on the menu page. Well, if you go to the menu page, you'll find a box on the left that's titled "Theme Locations". There's a drop-down menu in this box. Click it and select the name of the menu you created. That should solve your problem.

    Let me know if it doesn't and I'll see if there's anything else I can do. =)

    Best of luck,

    -AB
    http://brownbair.com

  17. selarsen
    Member
    Posted 3 years ago #

    @brownbair
    Thanks for you help. I have already created the menu exatctly as you describe. No change...

    @voyagerfan5761
    Thanks for replying to this thread!!

    @ ALL

    I just downloaded a fix provided by andrei luca on twitter:

    ***@se1988 please download this fix http://www.box.net/shared/m4c03g2lj3 (overwrite needed)***

    That did the trick!!
    A big thank you to everyone taking their time looking into this:D

    -Sven Erik
    selarsen.com

  18. chrisanthropic
    Member
    Posted 3 years ago #

    I'm still on version 2.0.0.6 of the theme and the files selarsen posted above didn't do the trick...I'm guessing a manual update to .7 is necessary?

    *edit*
    Nevermind, I forgot I had the theme set to use the "wide" setup. Changing it back to "original" worked with the new files.

    Thanks!

  19. Gagan Jain
    Member
    Posted 3 years ago #

    I get some same issues like you guys when click on no sidebar it disable sidebar but it does change background
    I have set it wide and tried original too but it look same
    Look at image
    http://img153.imageshack.us/img153/8207/lightwood2.jpg

  20. Gagan Jain
    Member
    Posted 3 years ago #

    I did't get brownbair post where do i have to post following code

    <link rel='stylesheet' id='lightword_stylesheet_single-page-template-css' href='http://YOURPAGE.com/wp-content/themes/lightword/single-page-template.css?ver=2.0.0.6' type='text/css' media='all' />

    In in the single-page-template.php file you have post this code <?php wp_head(); ?>
    Correct me if i am wrong

Topic Closed

This topic has been closed to new replies.

About this Topic