WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Lightbox only shows up after second click (13 posts)

  1. docwisdom
    Member
    Posted 1 year ago #

    I have the latest version of nextgen installed on WordPress 3.4.2 and Lightbox plus.

    The problem I am having is that I add a imagebrowser to my post and the first time you click on an image, it navigates to the source image in the browser full screen. If you then click back and click the same image again, it pops up in lightbox like its supposed to. This occurs with every image.

    Any thoughts on why this might be happening? Thanks

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. wombosi
    Member
    Posted 1 year ago #

    if you go to gallery>options>gallery settings is "show imagebrowser" checked?
    if it is try unchecking it.

  3. docwisdom
    Member
    Posted 1 year ago #

    its unchecked

  4. wombosi
    Member
    Posted 1 year ago #

    there's gotta be a setting somewhere either in nextgen or in lightbox plus that is causing this. or possibly another plugin conflicting.
    sorry i can't be of more help.

  5. docwisdom
    Member
    Posted 1 year ago #

    Ya I figured the same but I dont have enough experience with WP to know where to start.

    Thanks for the attempt

  6. wombosi
    Member
    Posted 1 year ago #

    yeah, just poke around and read through all the options. make sure you don't have another image-related plugin that could be conflicting.

  7. docwisdom
    Member
    Posted 1 year ago #

    so far just the built in media library, nextgen and lightbox plus

  8. wombosi
    Member
    Posted 1 year ago #

    well, i know this might sound like a crappy solution, but have you considered trying a different lightbox plugin?
    i use simple lightbox and it works great.

  9. docwisdom
    Member
    Posted 1 year ago #

    gave that a shot, now lightbox doesnt show up at all

  10. wombosi
    Member
    Posted 1 year ago #

    you have to "enable lightbox"
    go to plugins, installed plugins, then you'll see it there and click settings.
    also go to gallery>options>effects and make sure "none" is selected.
    incidentally, this might have been messing up your previous lightbox plus.

  11. docwisdom
    Member
    Posted 1 year ago #

    i went back to lightbox plus and in gallery>options>effects I had "lightbox" selected. When I tried NONE like you said it failed to load lightbox at all. I can give simple lightbox a try again.

  12. docwisdom
    Member
    Posted 1 year ago #

    Your suggestion worked with simple lightbox.

    Just wish it operated and looked as pretty as lightbox plus.
    Thanks for the help diagnosing though!

  13. wombosi
    Member
    Posted 1 year ago #

    yes, try it again.
    that NONE setting was critical for me.
    simple setting somewhere is messing you up.
    going to sleep. hope you get this solved as it's starting to stress me out.

    by the way, i assume when you tried simple lightbox that you removed/deactivated lightbox plus?
    whichever one you're trying to use you need to make sure it's enabled, not just the plugin activated, and that wordpress and nextgen aren't trying to do their own thing on top of it/behind it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags