WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox-Like Plugin? (7 posts)

  1. oseary
    Member
    Posted 7 years ago #

    I love [the function of] the Lightbox plugin. However, I can never get it to work properly. I.e. currently on my site:

    http://www.pesosforpenguins.com

    I have it "activated," but when I click an image, it just takes me to another page with the image, not the Java powered popup.

    However, on my photo arhcives page (with the Flickr plugin for my album that combines the Lightbox functionality) it works perfectly. I didn't code anything into the other page, it just works with the Flickr plugin.

    What do I need to code into my page, to make sure that the lightbox thing works?

    I've tried the dev site, but received no answer.

    Thanks for any suggestions!

  2. yosemite
    Member
    Posted 7 years ago #

    Depends which plugin, there are a few lightbox plugins out there... My issues seemed to always boil down to the plugin not finding itself. I would have to put my own path in to the plugin file, replacing whatever 'dynamic' method they butchered err used to find itself.

  3. dbasulto
    Member
    Posted 7 years ago #

    perhaps you have another java script loading on your main page, preventing lightbox java code to run properly?

  4. oseary
    Member
    Posted 7 years ago #

    I thought about conflicting JS, but narrowed it away from that when it didn't even try to load the JS (in the plugin) but just went straight to the "other page."

    I've never been able to get this plugin to work, but I love its functionality. I am just not good with coding, or finding out what is causing my issue

  5. oseary
    Member
    Posted 7 years ago #

    What it seems like is that i have to add some attribute to every photo that I upload.

    WTF?

    Am I the only one who feels that I shouldn't need to do this for it to work? Or, is there a plugin out there that doesn't need this to work?

    EDIT: THIS ATTRIBUTE IS NOT NEEDED FOR MY VERSION OF THE PLUGIN. What it seems like is that it just cannot "find" the plugin itself, I am not the only one pulling his hair out on this. :-)

  6. yosemite
    Member
    Posted 7 years ago #

    What it seems like is that it just cannot "find" the plugin itself, I am not the only one pulling his hair out on this. :-)

    Did you see my post?

  7. oseary
    Member
    Posted 7 years ago #

    Yea... I realized that it "cannot find" the plugin... Then that reverts back to me not knowing how to code, then me trying to code, then me breaking my blog. Lol...

    I'm still trying to find a solution...

Topic Closed

This topic has been closed to new replies.

About this Topic