WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] li CSS question (8 posts)

  1. OrchidRed
    Member
    Posted 8 years ago #

    I'm trying to make a 1px border to appear around list items in my posts, but I just can't get it to work. A border appears when you hover over a list item (which I also want) but as soon as the mouse moves away the border dissapears.

    Any CSS wizards out there willing to help a gal out?

    Here is the code I'm using:

    .post li {
    margin-bottom: 8px;
    margin-left: 0px;
    padding: 3px 8px 3px 20px;
    background: #F3EEDF;
    border: 1px solid #CBC987;
    }

    .post li a {
    }

    .post li:hover {
    border: 1px solid #AEA94C;
    }

  2. spencerp
    Member
    Posted 8 years ago #

    I'm *not sure* if you have tried this or not..but, here try this..

    .post li:a { border: 1px solid #CBC987; }

    or maybe even..(doubtful though maybe)

    .post li a { border: 1px solid #CBC987; }

    That *should* work, because you even said, it works when *hovering* over it.. which you already have a "class" for it.. you just need one for the "li:a" now.. I hope this helps..

    spencerp

    Then for the "color code" there.. use what ya want.. ;) :) I *hope* this is what ya want lol.. =/

  3. OrchidRed
    Member
    Posted 8 years ago #

    Nope that didn't do it. :(

    Thanks for the suggestion though spencerp, I appreciate your taking the time!

  4. spencerp
    Member
    Posted 8 years ago #

    Hmm.. let me see once.. how about:

    .post li:a {
    margin-bottom: 8px;
    margin-left: 0px;
    padding: 3px 8px 3px 20px;
    background: #F3EEDF;
    border: 1px solid #CBC987;
    }

    I'm not really sure, if you're talking about the "blog" in your profile name.. or not.. have a URL to the one in question then? ;) I can get a better "idea" of what's going on that way then.. ;)

    spencerp

  5. OrchidRed
    Member
    Posted 8 years ago #

    Ah ha! I fixed it. A second class (.entry) was over riding the .post class. Yay!!

  6. OrchidRed
    Member
    Posted 8 years ago #

    yes, I was talking about http://www.themutteringmuse.com. Thank you for your help spencerp, your suggestion made me wonder whether I was over riding the li coding somewhere else since you said it was ok.

  7. spencerp
    Member
    Posted 8 years ago #

    Awesome! Glad to hear ya fixed it.. =)

    spencerp

  8. spencerp
    Member
    Posted 8 years ago #

    yes, I was talking about themutteringmuse.com. Thank you for your help spencerp, your suggestion made me wonder whether I was over riding the li coding somewhere else since you said it was ok.

    Oh ok, I was thinking that's the one you were talking about.. =P You're welcome with the helping.. =)

    Atleast ya found the culprit, and fixed it now.. =) Nice theme by the way..! ;)

    spencerp

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.