WordPress.org

Ready to get started?Download WordPress

Forums

s2Member Framework (Member Roles, Capabilities, Membership, PayPal Members)
Level1 and 2 Menus Have Suddenly Become Visible to All (2 posts)

  1. ted_smith
    Member
    Posted 4 months ago #

    Hi.

    I use s2Member and the Awake 3.4 theme.

    When I first set it all up, I had a series of menus across the top created via the formation of pages.

    I then set s2Member page restrictions for some of them to Level1 or above so that only logged in members could see the particular menus.

    However, at some point (I think since either updating WP to 3.8.1 or after updating s2Member) these restricted pages have become accessible to all users, logged in or not! I only just noticed today.

    I checked the page restrictions and they were all still set as 1 and all the Page ID's are listed as level 1 in s2Member. So I tried lifting them all to Level2 to see if that made a difference. It didn't. They are all still accessible!!

    For now, I have created a new Level 0 page "You must be logged in to see this page content" in the 'General Options' --> 'Membership Options' area of s2Member which works as a temporary prevention of access, but the menu titles are still visible in the menu area and I wish to block that for anonymous users like it used to be.

    Have I done something wrong or is this something that has become broke? I am using s2Member v140105

    https://wordpress.org/plugins/s2member/

  2. KTS915
    Member
    Posted 4 months ago #

    I am using s2member and cannot reproduce the problem you describe here, but I can suggest a workaround. You will need to install and activate the plugin Display Widgets.

    Now go to Appearances - Widgets, and drag the Custom Menu widget to a suitable widgetized area. Select the Menu you want to display, and use the Display Widgets options to set whether the menu can be accessed by everyone, or only by those logged in or logged out.

    Rinse and repeat to set different menus for different users.

Reply

You must log in to post.

About this Plugin

About this Topic