WordPress.org

Ready to get started?Download WordPress

Forums

Twenty Eleven
Length of post shown on Showcase page (7 posts)

  1. zanzaboonda
    Member
    Posted 1 year ago #

    Hi there-

    I was wondering if there is a way to change the lengths of the posts on the Showcase template. I've tried using the More tag, naturally, but it causes a problem with one of my plugins (MapPress maps suddenly move to the top of the post and display before anything else.)

    Is there any other way to do this? I already have a child theme.

    Thanks in advance.

    Best wishes,
    Kristen

  2. Demetrius Pop
    Member
    Posted 1 year ago #

    I think I actually just saw that a minute ago. Admin > Settings > Writing > Size of the Post Box.
    Hope that helps.

  3. zanzaboonda
    Member
    Posted 1 year ago #

    I'm going to feel silly if that's all it is. LOL I'll check that out and see if it works for the Showcase template. Thanks so much!

  4. Demetrius Pop
    Member
    Posted 1 year ago #

    Did that work? If not, and you are wanting to make your post longer, then the more tag, I think, is used to make the post shorter. To make it longer:
    inside of your loop,
    use this: (exclude tics, of course)

    <?php the_content(); ?>

    in place of this:

    <?php the_excerpt(); ?>

  5. zanzaboonda
    Member
    Posted 1 year ago #

    Hey there!

    Sorry it took so long to respond. I think the first option just changes the size of the box you're writing in. :/

    I was hoping to make the post appear shorter, using the more tag, but when I use it, other custom post fields "break", so to speak, and show up in the excerpt, even when they are after the more tag, if that makes sense. It's quite vexing. lol

    Thank you for your help. I do appreciate it.

  6. Demetrius Pop
    Member
    Posted 1 year ago #

    Welcome! Just in case you're not currently using the_excerpt, that would make the post shorter.

  7. zanzaboonda
    Member
    Posted 1 year ago #

    Thanks for continually trying to help me. :)

    The problem I'm having is specifically with with the Showcase page template. (I'm having another problem, which I posted separately.)

    Here's the site I'm working on right now:
    http://zwoodle.com/

    So I have the Showcase template for the front page. As it's set up, there is the showcase slide show at the top, then the first post contains the entire post, then the rest of them are title only.

    I didn't really want the entire post to show up like that, so I wanted to use the more tag. Seems straight forward. However...

    The map that you see on the post gets shifted up to the top of the post, above everything else, whenever I use the more tag. Pretty ugly.

    I know it's the standard theme and all, but it works well for my needs right now. I just can't figure out what's going on here, lol, or in the other situation.

    I might have to forego the whole showcase thing and find another way to do this, but I'd rather keep it simple, if I can.

    Anyway, thanks again. :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic