WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow Satellite
[resolved] Legacy IE (7&8) jQuery Error (11 posts)

  1. Ash Durham
    Member
    Posted 1 year ago #

    Hey,

    Just wondering if your aware that your plugin dies on IE7 and IE8 on a jquery error. While the jquery file is on every page, it does not error until my gallery page. I checked your site and it also dies.

    Any chance of a fix?

    http://wordpress.org/extend/plugins/slideshow-satellite/

  2. Ash Durham
    Member
    Posted 1 year ago #

    Some further information on this, I have tried it with jquery version 1.8.3 and it doesn't work, but does in all other browsers. 1.9.0 and 1.9.1 it doesn't work anywhere. Same error in chrome using 1.9.1 as the error in IE7 and 8 using 1.7.2. Something about 'hover'.

  3. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    Good to know! I'll look into it and hopefully find an easy fix. Being on a mac it's a little hard to test, so if anyone else sees a good solution feel free to speak up!

  4. Ash Durham
    Member
    Posted 1 year ago #

    As mentioned, using the latest version of jQuery will allow you to replicate the error in chrome which should help in finding a solution. It's an unusual error since its producing the error in jQuery itself, not in your script. Due to the error though, your script does indeed fail but that doesn't necessarily mean they are related.

  5. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    In Advanced Settings you can switch between WordPress jQuery and Google jQuery, have you toggled those to see if it makes any difference?

  6. Ash Durham
    Member
    Posted 1 year ago #

    I had it on google originally. Flicked over to wordpress, but it still continues to draw the jquery file from google.

    That aside, as mentioned above, I tried a number of different versions and got the same result, so I don't think that one is the problem.

  7. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for pointing this out!

    I see I'm not the only one whos script had that problem. Here's a potential solution

    http://stackoverflow.com/questions/13729136/jquery-ishover-in-ie8

  8. Ash Durham
    Member
    Posted 1 year ago #

    So will you be releasing an update with this fix?

  9. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    Yes! please bear with me as I finish up a major fix, transitioning from 1 slide table to another slide table.

  10. cpres
    Member
    Plugin Author

    Posted 11 months ago #

    it's in the 2.1 release!

  11. Ash Durham
    Member
    Posted 11 months ago #

    Great, Thanks mate

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.