WordPress.org

Ready to get started?Download WordPress

Forums

Leaflet Maps Marker, W3 Total Cache & MaxCDN (2 posts)

  1. ap3design
    Member
    Posted 1 year ago #

    I haven't seen this reported anywhere else. I am running the latest WordPress version 3.5.1 and the latest Leaflet Maps Marker plugin version 3.5.2. Everything was working fine until I started using W3 Total Cache along with MaxCDN. Now, my map markers (except the default one) do not show up on the maps.

    Please see ayso13.org/maps/ for an example.

    Investigating further, I see that there is a problem with the path for the map markers.

    "NetworkError: 404 Not Found - http://cdn.ayso13.org/wp/wp-content/uploads/leaflet-maps-marker-iconscommunitycentre.png"

    Notice that the forward slash between the maps marker directory and the name of the marker file is missing. This does not happen with the default icon. Also, I have no issue with delivering other media files from the can.

    Is this a bug or have I missed a setting somewhere?

  2. jdorfman
    Member
    Posted 1 year ago #

    Hey @ap3design

    I am seeing a 302:

    curl -I "http://cdn.ayso13.org/wp/wp-content/uploads/leaflet-maps-marker-iconscommunitycentre.png"
    HTTP/1.1 302 Found
    Date: Tue, 12 Feb 2013 00:47:49 GMT

    Try purging your cache on the CDN and W3 Total Cache. Email me if you still have issues: jdorfman at maxcdn dot com

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags