WordPress.org

Ready to get started?Download WordPress

Forums

Achievements for WordPress
[resolved] Leaderboard Blank (16 posts)

  1. pawparazzo
    Member
    Posted 8 months ago #

    Hello. Fantastic plug-in!

    I have integrated the Leaderboard Widget - but get nothing displaying other than the title "Leaderboard" There should definitely be some entries.

    Not sure what I'm doing wrong.

    http://wordpress.org/plugins/achievements/

  2. pawparazzo
    Member
    Posted 8 months ago #

    Sorry - Should have added the details.

    Achievements: 3.4.1
    WP: 3.6.1 (Multisite) (Theme is Razor from Themeforest)
    BP: 1.8.1

  3. pawparazzo
    Member
    Posted 8 months ago #

    Another quick follow-up to advise that I deactivated ALL plugins with the exception of Buddypress and Achievements ... no change ... Leaderboard widget still only displays a title.

  4. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 8 months ago #

    Hmm. :( This is going to require some investigation.

    1) Thanks for testing with deactivating all plugins. Which theme are you using? Have you tested deactivating ALL plugins AND switching to a default WordPress theme (i.e. twentytwelve)?

    2) Can you confirm that at least 2 of your members have unlocked an achievement(s), and that those members now have more than 0 karma points? You can check karma by going into the WordPress admin, and clicking on the [Achievements] -> [Users] menu item.

  5. pawparazzo
    Member
    Posted 8 months ago #

    Thanks for the reply, Paul.

    I'm using the Razor Theme from Themeforest. I have switched to the default theme (twenty twelve) AND deactivated all plugins, with the exception of BP and Achievements - unfortunately, the result is the same - a blank Leaderboard with the heading only.

    I can also confirm that 4 of my test site members have unlocked at least two achievements each.

  6. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 8 months ago #

    I can also confirm that 4 of my test site members have unlocked at least two achievements each.

    And definitely have at least 1 karma point in their user profiles, yes?

  7. pawparazzo
    Member
    Posted 8 months ago #

    Yes - Many more points than 1.

  8. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 8 months ago #

    Anything special about how these user accounts were created? Were they created from any social media account/sign-on plugins?

  9. pawparazzo
    Member
    Posted 8 months ago #

    No - nothing special. The accounts were created and activated by test users through the BP sign-up form.

    I will try creating a couple of accounts via the WP admin backend (then let them gat a couple of achievements) and see if that makes a difference.

  10. pawparazzo
    Member
    Posted 8 months ago #

    I set a couple of users via the admin panel - they obtained achievements - but the Leaderboard widget remains blank - nothing other than the title displays.

  11. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 8 months ago #

    Still thinking about possible causes, but no decent ideas yet.

    Where's your site hosted -- which host?

  12. pawparazzo
    Member
    Posted 8 months ago #

    We're hosted on hostpapa.ca

  13. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 8 months ago #

    Ok - was wondering if they had any special caching for WordPress automatically provided, but looks like a fairly generic web host.

    Beginning to suspect this is related to your other support issue with the shortcodes. Both problems are very strange.

  14. pawparazzo
    Member
    Posted 8 months ago #

    The Leaderboard Widget is not displaying results.

    Here is what I did:

    1) I am on a Mutisite WP install - but only have one site running. I deactivated the Achievement plug-in on the Multisite dashboard - but left it activated on the individual site.

    2) When I upgraded Achievements to 3.5 I ran into an issue with shortcode no longer processing on any of the "Achievements" detail pages (Separate Support issue). At that point I completely removed the plug-in and re-installed 3.4.1. Upon activation (Network deactivated) the Leaderboard widget began displaying results.

    Thanks for the help Paul - this is a FANTASTIC plugin and I think it's working properly now. I imagine the re-install was what solved the problem. I still want to upgrade to 3.5 - but am a bit concerned about the shortcode issue - regardless, shall do the upgrade soon and report results in the other support issue thread.

  15. pawparazzo
    Member
    Posted 8 months ago #

    Oops - just saw that there is a typo in that last comment I made .. it should say.. The Leaderboard Widget is NOW displaying results.

  16. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 8 months ago #

    I'll do some testing against multisite to see if I can recreate any issues.

Reply

You must log in to post.

About this Plugin

About this Topic