WordPress.org

Ready to get started?Download WordPress

Forums

Latvian letters not saved/displayed in the Blog's Title (4 posts)

  1. Guntis
    Member
    Posted 4 years ago #

    I open admin General Settings and there is Blog Title field. I enter there "Adventistu Cēsu draudze" but after saving that I get "Adventistu C?su draudze". All WP database is manually converted to utf-8, all fields have utf-8 encoding. Why Latvian letters aren't saved? I can't enter Blog's title properly…

    http://www.cesis.adventisti.lv/

  2. lokrin2000
    Member
    Posted 4 years ago #

    If you know how to get in your database and directly change it there, that might work. I know I had to do that when it kept changing an 's to an /'s in the blog title .

  3. Guntis
    Member
    Posted 4 years ago #

    If I'm correct, that information is stored in 'wp_options' table in 'blogname' field, and there it is saved properly. Problem seems to be connection & encoding when fetching this data. Looks like encoding is Latin when it should be utf-8.

  4. Guntis
    Member
    Posted 4 years ago #

    By the way, all these years for every WP update I have to change wp-settings.php file by adding two extra lines at the end of the file:

    // Everything is loaded and initialized.
    do_action('init');
    mysql_query("SET CHARACTER SET utf8");
    mysql_query("SET NAMES utf8");
    ?>

    If there are no these mysql_query lines all blog is messing up all Latvian letters. It's beyond my comprehension why WP team can't add these lines so that WP would work correctly out of the box. by the way, out of the box it creates db with swedish cp encoding. why?

Topic Closed

This topic has been closed to new replies.

About this Topic