WordPress.org

Ready to get started?Download WordPress

Forums

My Shortcodes
[resolved] Latest version of plugin breaks my existing shortcodes (5 posts)

  1. cbattle
    Member
    Posted 11 months ago #

    First off, let me say thanks for a really useful plugin (Caldera My Shortcodes). I have built about 15 custom shortcodes for a site that I am working on and it has been great. However, I just upgrading the Caldera shortcode plugin today (along with some other plugin updates & a Voyage theme update) and now my existing Caldera shortcodes are not working. It seems like it is now having a problem loading the JS files. I am getting errors saying certain functions don't exist but they are in JS files that I am including in my header.php file. (I tried putting the references back into the Libraries section of the shortcode but that didn't help either.) It seems like the shortcodes are loading before the JS files so they are not recognizing the function calls, and thus not working. Any ideas about how to fix this?

    We were going to go live with the site next week but now I am in a terrible state with much functionality not working, since I am using so many shortcodes. I'm not sure why the code & JS files would now be loading in a different order but I am feeling like that is the problem. I will continue troubleshooting this but if you have any ideas about what to do I would greatly appreciate it.

    Thanks! :-)

    Corinne

    P.S. It is an internally hosted site so I can't give you access, unfortunately...

    http://wordpress.org/plugins/my-shortcodes/

  2. David Cramer
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Corrine,

    Can you export the shortcodes and send me the file?
    I can take a look and help out. you can get my email address from the send feedback link in the plugin.

  3. cbattle
    Member
    Posted 11 months ago #

    Ok I will try to do that. Thanks! :-)

  4. cbattle
    Member
    Posted 11 months ago #

    Just sent you an email...thanks! :-)

  5. David Cramer
    Member
    Plugin Author

    Posted 11 months ago #

    First suggestion.
    click edit on an active element. Then save and close.

    Then load a page with a shortcode on and press CTRL+R
    see if that helps.

    I'm still checking things my side.

Reply

You must log in to post.

About this Plugin

About this Topic