WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
[resolved] Latest version - no S3 back up? (18 posts)

  1. amanuensis
    Member
    Posted 1 year ago #

    Hi
    I have just upgraded to the latest version of your plugin - the previous version had the ability to backup to Amazon S3, this was my preferred choice - after upgrading to the latest version there is nowhere, at least I can't find anywhere, to re-insert the S3 settings , at the moment I am left with no way to back up as previously to S3
    What am i missing?

    http://wordpress.org/extend/plugins/backwpup/

  2. Dominik Schilling (ocean90)
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    That's now a feature of the PRO version. Take a look at the comparison: http://marketpress.com/product/backwpup-pro/?noredirect=en

  3. mrkingid
    Member
    Posted 1 year ago #

    that is not true. backing up to S2 is still in the free version.

    Try updating to 3.0.2

  4. grahamjones
    Member
    Posted 1 year ago #

    Absolutely, the comparison clearly shows that Amazon S3 is in the FREE version.

  5. amanuensis
    Member
    Posted 1 year ago #

    Hi mrkingid

    Thanks for replying - I am running v3.0.2 thats when the facility for S3 disappeared from the settings - any ideas.
    i have a lot of WP sited using the plugin but can't afford to have this happening to them, is there a way of getting back to the previous version as that seemed to work really well?

    Many thanks in advance for any help

  6. mrkingid
    Member
    Posted 1 year ago #

    You can get the older versions here...

    http://wordpress.org/extend/plugins/backwpup/developers/

    and do a manual install through ftp.

    no idea why the S3 would disappear in 3.0.2. Maybe do a clean uninstall and re-install of 3.0.2 first?

  7. rodbauer
    Member
    Posted 1 year ago #

    I had the same issue on one server until I upgraded the version of PHP running on it and then the S3 option was available.

  8. Jeff Rose
    Member
    Posted 1 year ago #

    Confirming I have the same problem. There is no setting/option for S3 in the free plugin.

    I did remove the plugin and re-install from the Repo with no effect.

  9. mbrsolution
    Member
    Posted 1 year ago #

    Hi please read this thread
    http://wordpress.org/support/topic/s3

    Kind regards

  10. Jeff Rose
    Member
    Posted 1 year ago #

    Yup, that explains it.

    You might want to include that in the DETAILS of the upgrade documentation.

  11. grahamjones
    Member
    Posted 1 year ago #

    No that does NOT explain it. What it means is that the provider of the plugin expects users to delve inside the code and change it.

    Not good at all.

    I predict many people, like me, will be searching hard for an alternative.

    Look on the support forum for BackupWP and within a day there are dozens of complaints about a wide array of errors produced by the new version.

    I suggest - switch back to the old version, search for alternatives.

  12. seville76
    Member
    Plugin Author

    Posted 1 year ago #

    @grahamjones, I'm sure Daniel will fix the problems very soon. So be patient and wait until Monday at least before switching to another solution.

  13. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    S3 disappear when PHP version lower than 5.3.3. Because the new Amazon SDK needs it.

  14. nadworks
    Member
    Posted 1 year ago #

    Daniel, sowas teilt man seinen Benutzern vor oder zumindest während des Upgrades mit, anstatt sie damit alleine zu lassen!!!!

  15. grahamjones
    Member
    Posted 1 year ago #

    I have PHP version 5.4 but no Amazon S3 available. Every reply you give me so far is simply not proving to be true. I have lost confidence in this plugin and your ability to support it.

  16. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    @nadworks: du hast recht. Ich hätte es nicht nur im Change Log erwähnen sollen.

    @grahamjones: i have tested it with PHP 5.4.9 and it works.

  17. grahamjones
    Member
    Posted 1 year ago #

    Well it doesn't for me.

    I have switched to Updraft which works perfectly

  18. joeventures
    Member
    Posted 1 year ago #

    According to the Amazon SDK requirements, it also requires "A recent version of cURL 7.16.2+ compiled with OpenSSL and zlib."

    Keep in mind, seeing that Updraft hasn't been updated in more than two years, you may eventually want to move back to backwpup. There may come a point when the older Amazon SDK will no longer work. Sorry that your configuration doesn't work with the new SDK. Mine doesn't either, but that's because I'm on a slightly older version of php. As a temporary solution, I'm using ftp to back the files up to a different host. Hopefully, the host will upgrade my production server someday ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags