WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Latest version breaks some wp-admin links in multisite (8 posts)

  1. figureone
    Member
    Posted 1 year ago #

    After upgrading from 3.3.0 to 3.3.5, several links in Network Admin broke.

    Example: Plugins page
    /wp-admin/network/plugins.php
    Several of the links on this page (e.g., "Add New", "View version x.x details", and "update now") have "wp-admin/" stripped out of the URL.

    For example, the "Add New" button at the top of the page should point to:
    /wp-admin/network/plugin-install.php
    But instead points to:
    /network/plugin-install.php
    WordPress Multisite rewrite rules don't know what to do with the latter, so a 404 is returned.

    This behavior was introduced in the latest update.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. figureone
    Member
    Posted 1 year ago #

  3. ImprovePhotography
    Member
    Posted 1 year ago #

    I am also using the plugin and have the same issue in multisite. As soon as a user goes to a secure page on my site, each link sends them back to the home page.

    You can see this happening by going to improvephotography.com/courses and then clicking around. As soon as it goes https, it goes wild.

  4. Beshoy Girgis
    Member
    Posted 1 year ago #

    I too am having this problem, tracked it down to this plugin.

  5. jeroenwilms
    Member
    Posted 1 year ago #

    I'm experiencing the same trouble. It also seems to conflict with the OnTheGoSystems Installer from WPCompatibility.

  6. Gabriel Serafini
    Member
    Posted 1 year ago #

    I'm also seeing the problem on multisite install, it strips the wp-admin/ from the main site's internal URLs. I'm using a directory-based install (not subdomains).

  7. jeroenwilms
    Member
    Posted 1 year ago #

    Just dropped Mike (developer) a note take a look at this. Hope he will respond.

  8. danielj@dtdo.net
    Member
    Posted 1 year ago #

    I am experiencing this as well. It was driving me crazy! I disabled it on our test server and will not upgrade our production server yet.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic