WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] Latest update causes post edit options to disappear (11 posts)

  1. Talonz59
    Member
    Posted 11 months ago #

    I'm using the Suffusion theme on both a hosted server and WAMP locally. After updating the Google Translator plugin to 1.6 I began to notice things like the categories list in the post edit page was blank. As well, text and radio buttons were missing from some the options of widgets in the appearance panel. I thought it could have been a theme issue and activated the 2010 theme but had the same results. One by one I deactivated all plugins and double checked the post edit page to see if the list of categories came back and sure they did once I deactivated the Google Translator plugin. I reactivated all previous plugins with no issues until I activated the translator plugin.

    http://wordpress.org/extend/plugins/google-language-translator/

  2. Teresaezc
    Member
    Posted 11 months ago #

    I found the same problem with my Yoko Theme, Talonz59, and I followed the same process you followed too. There's no doubt that is a problem with this pluggin.

  3. Rob Myrick
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks for the update - I'll check into this ASAP - it might have to do with some of the styling running over into the other admin pages - those styles were added in 1.6. I will update ASAP. Version 1.5 probably won't have the same issues if you want to revert back to that version in the meantime - thanks!

  4. Rob Myrick
    Member
    Plugin Author

    Posted 11 months ago #

    Hello everyone, I updated the plugin once again with some crucial fixes. Styles were being added to all pages of the WordPress dashboard, instead of being added to the specific settings page, which is why you probably had display issues. Please update to version 1.7 and let me know if you still experience issues.

    Thanks, Rob

  5. datawebp
    Member
    Posted 11 months ago #

    From what I can find, it's google-language-translator\google-language-translator.php, lines 21-23 add a style block in the head which sets all "label" fields to display:none; Well, when you're in the admin side, that means all your normal edit forms which incorporate lables -- all the labels are missing! Not so good. Can you find a way to do what you're wanting that doesn't cause a global hiding of all label tags???

  6. Talonz59
    Member
    Posted 11 months ago #

    Applied the update and all is well again, thank you for your efforts Rob, they're greatly appreciated. Just reread my original post.....lack of sleep makes for terrible grammar :)

  7. Rob Myrick
    Member
    Plugin Author

    Posted 11 months ago #

    Hi datawebp, did you download the very most recent version of the plugin (1.7) as of a few hours ago? I just updated to take care of this - sorry for the inconvenience. The CSS styles are now restricted to the settings page only.

    Let me know if you are still experiencing issues.

    Thanks!

  8. Rob Myrick
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks Talonz59....that's great! Let me know if anything else comes up.

    Thanks, Rob

  9. datawebp
    Member
    Posted 11 months ago #

    Excellent! Lol, it was funny because I commented out those lines I mentioned above, and loaded them up...and literally within seconds, the update appeared in the admin panel for the component. :D Thanks for the update!

  10. Rob Myrick
    Member
    Plugin Author

    Posted 11 months ago #

    Nice! I'm glad it worked....thanks for letting me know!

  11. Rob Myrick
    Member
    Plugin Author

    Posted 11 months ago #

    I'm closing this topic as I believe it is resolved.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.