WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate TinyMCE
[resolved] Latest Update Brings Load Time of Website to a Crawl (15 posts)

  1. pgale2
    Member
    Posted 1 year ago #

    The most recent update of Ultimate TinyMCE brings my site and my clients (the ones that I updated) to a crawl regarding load time.

    I tested this many times with deactivating and re-activating... it's definitely the plugin.

    http://wordpress.org/extend/plugins/ultimate-tinymce/

  2. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Okay... Please let me run some tests and see if I can replicate.

  3. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Okay. I'm sorry.

    Version 4.3.1.3 is being uploaded now.

    I will make sure I do not release another update until I'm absolutely positive I have the new functionality working properly.

    I am going to start a Google group for beta testers.. and will post the link publicly so others can follow.

    Thank you for bringing this to my attention!!

  4. pgale2
    Member
    Posted 1 year ago #

    Thank you!

  5. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    You're very welcome!

    Okay.. the new version is available.

    You can go to your WP Dashboard -> Updates -> and click "check again".

    This should make the update available immediately for you to install.

    Please let me know if this fixes the issue for you.

  6. nturillo
    Member
    Posted 1 year ago #

    Same problem as pgale2, I had a backup copy of ver 4.2 which I reinstalled on both sites for now. I'll stay with that version until all problems are solved.
    Also I did notice with the new update that the plugin FWB Slider Pro stop working when the new version of Ultimate TinyMCE was activated.
    I do have a copy of WP on my Mac with MAMP, running as a test area, once you have another version I'll test it there first.

  7. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    I'm absolutely positive it's all fixed in version 4.3.1.3.

    I have some testing to do before releasing the new features I was hoping to incorporate into this plugin. This was my first test.. and it failed miserably. So, I have to pick up the pieces... do some further researching... and build it from a different angle.

    But, the offending code has been removed... and the newest version (4.3.1.3) will address the loading times.

  8. nturillo
    Member
    Posted 1 year ago #

    I'll give it another try on one of my site and let you know how it goes.

  9. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Thank you! I'm standing by...

  10. nturillo
    Member
    Posted 1 year ago #

    Ok I reinstalled the latest ver and all seems to work fine, even the FWB Slider Pro plugin.
    Didn't effect the load time at all. I also tried it on my WP copy on my MAC and all works fine.

  11. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Thank you VERY much!

    Again... I'm very sorry for the inconvenience.

  12. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Since everyone is reporting this as working now... I'm going to mark the thread as resolved.

    @pgale2, please feel free to change it back if this is still not working properly for you. Thanks!

  13. leehodson
    Member
    Posted 1 year ago #

    Hey Josh, hiccups happen, you're doing a great job with this plugin. Thank you.

  14. Texiwill
    Member
    Posted 1 year ago #

    This issue did not go away as the wp_footer action to constantly call Amazon S3 was not removed. My security systems actually picked it up as an attack....

    SOlution:

    Comment out the following in main.php:

    #add_action('wp_footer', 'jwl_rocket_button');

    Which solved the problem for me... Not sure why you need to go to S3 everytime the site is loaded... Could we not cache things or have an option to disable?

    -Edward

  15. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 1 year ago #

    Sure, I can set it as an option to disable... or find a better solution.

    I am working on two new ideas for features. One is a visual QR code functionality.. allowing usage of ANY image as the background of the QR code. It's really cool. However, images will have to go through a "verification" process with the company we are using to put all this together. So, I'm jut not quite sure how I'm going to handle that request at this point. Hence, the testing of the code.

    Secondly, I am working on a feature which would require "dynamic" content to be used in the plugin. This option, of course, will be optional.. and set to disabled by default. I don't want to talk too much about it at this time... as it's relatively new.. and I don't want anyone to "steal" it ;)

    However, using the option will give the plugin (and website) a much more "interactive" feel... while not requiring constant updates to the plugin.. which WP frowns upon.

    I hope this helps clarify. I'll add the option to disable in my next update. Please remind me here if I forget.

    Thank you very much!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.