WordPress.org

Ready to get started?Download WordPress

Forums

iCafe Library
[resolved] Latest Database update seems to have broken icafe (7 posts)

  1. alexsbecker
    Member
    Posted 1 year ago #

    After upgrading to the latest WordPress database version, my iCafe Library broke in a couple ways. First, when I would click on a chapter, it would expand to the height of the largest section, (leaving lots of blank space - the inline height element was off), and then when I would click on the section, it wouldn't expand hardly at all (inline height element was set to 0). So I copied down my whole resource tree for safekeeping and deleted the whole plugin. Now that I've reinstalled it, I can't create sections. I can create books and chapters, but when I try to drag and drop something to nest below a chapter, it won't "stick," it just goes back to where it used to be. (If there's a way to do this outside of the UI, I'd love to know that too)

    Any help would be greatly appreciated, I just launched this site and presented it to a bunch of people, and now it's broken!

    http://wordpress.org/plugins/icafe-library/

  2. cnilsson
    Member
    Plugin Author

    Posted 1 year ago #

    Alexsbecker, I've replicated all the issues you are describing. It looks like 3.6 updated the core Javascript libraries. I'm working to make the library compatible. I will post an update as soon as possible. Sorry for the issues!

    Chris

  3. alexsbecker
    Member
    Posted 1 year ago #

    Thanks so much for your work! Love your plugin, I've been trying to find a replacement that I liked in case you didn't respond, and I haven't found anything else that comes close!

  4. cnilsson
    Member
    Plugin Author

    Posted 1 year ago #

    Found the issues...Wordpress 3.6 updated the included version of JQuery and JQuery UI from the 1.9 branch to the 1.10 branch. This new branch replaced a few deprecated functions that were included in 1.9 and that I relied upon in this plugin. I've updated the plugin to run on the latest versions of JQuery so that it works with WordPress 3.6. Just update the plugin to 1.7 and you should be good to go.

    Chris

  5. alexsbecker
    Member
    Posted 1 year ago #

    Thank you!!

  6. cnilsson
    Member
    Plugin Author

    Posted 1 year ago #

    No Problem...thanks for the heads up.

  7. gcdesigns
    Member
    Posted 11 months ago #

    I have actually found more issues that the update didn't cure. You can check out my site to see if I am nuts.. http://gcblogdesigns.com/support-library

    But I have clients complaining that the sections wont open for the different books (not the main, just the ones after that)

    They can't click the videos to watch them.

    I cant drop and drag anything and have it go in place or add smaller books to the main category books that I want and how I have it set up.

    Huge issue for me since this is a video support library for my clients. I hope this can be fixed I LOVE iCafe! I don't want to look for anything else...

    Please help

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic