WordPress.org

Ready to get started?Download WordPress

Forums

Social Media Badge Widget
[resolved] Last window stays open (11 posts)

  1. MarlyM
    Member
    Posted 7 months ago #

    Hello, thanks for the great-looking plugin. I'm enjoying using it so far but have a few suggestions.

    - BUG -
    * Whichever social network I add last will remain open / maximized, even without clicking on it. I tested this by deleting the last one on my list (Pinterest), but the one that became last on my list (YouTube) remained open once I refreshed the page, so the error is not confined to that one network.

    - POSSIBLE BUG -
    * Can't get Google+ to work for my G+ page. I tried each of these options, and none worked: {[the 21 digits of the main part of my Google+ URL]}, {0/[21 digits]}, {0[21 digits]}, {u/0/[21 digits]}

    - OTHER SUGGESTIONS -
    * It would be very helpful if there were a way to click on the social network title after opening its feed to close the feed again.
    * When either Twitter or Facebook is open, it takes up a lot of vertical space in the sidebar. Could we reduce the size?
    * LinkedIn Company badge does not seem compatible with having a left sidebar. Any way to use this without moving my sidebar?

    Thanks again. Take care.

    http://wordpress.org/plugins/social-media-badge-widget/

  2. MarlyM
    Member
    Posted 7 months ago #

    PS - I just tested this in a right sidebar, and LinkedIn still does not work because it goes under the content section of the site. Just a heads up.

  3. StressFree Sites
    Member
    Plugin Author

    Posted 7 months ago #

    Hi Marly,

    I'm pleased to hear that you like the plugin. Sorry to hear that you are also having issues with a couple of things.

    Firstly - BUG -
    Have you had a look at the a General Setting of the Social Media Badge Widget? Look under "Settings"->"Social Media Badge Widget" on the WordPress back end. You will see options for all sections to be closed at once, which section to open on load etc. It sounds like you might have a compatibility issue so you can toggle if you want jQuery loaded or not to try and help.

    Secondly - Possible BUG -
    You just need the 21 number which are in the URL when you view your profile. Make sure you put the digit in the profile ID box not the page ID box otherwise it won't work(unless you are putting in a page ID obviously!)

    Finally - Other Suggestions -
    1) This is the case see the one on the bottom right of my website(http://stressfreesites.co.uk/blog/2012/07/19/social-media-badge-widget/) - sounds like there is a compatibility issue. Let me know your URL and I might be able to assist.....
    2) The information is imported directly from Twitter and Facebook through a widget interface, the plugin just displays it. I could add the option of displaying the streams or not - I will think about it for the next update.
    3) This is true thank you for the idea :-) The LinkedIN content going under the main content is due to the "z index" of your content being set to a too large number - reduce this.

    I hope that all helps.

    Alex

  4. MarlyM
    Member
    Posted 7 months ago #

    Oops, I'm not sure how I've overlooked that second Settings page. Thanks for your quick responses. You were right; this gave me the option to leave all sections closed when the webpage loads.

    However, Google+ still isn't working for me. Mine is a page. I enter the 21 digits under page ID, but no dice.

    Re: Other suggestions --
    1) This works. After I edited some of the settings on that Settings page, sections started opening and closing as they should do.
    2) OK.
    3) Great, I may look into that.

    In short, everything that I mentioned before is now working as it should, except for Google+, which I am still having trouble with. Thanks again.

  5. MarlyM
    Member
    Posted 7 months ago #

    Please also be advised that the "Number of tweets to show" setting is also not working. I selected "1," but I see a ton.

  6. StressFree Sites
    Member
    Plugin Author

    Posted 7 months ago #

    Hi,

    No worries - great that finding the settings page fixed the majority of issues you had. :-)

    The Google+ can be a pain. It took me a couple of attempts to get mine working. I found that for a company page you have to have the company page open as be viewing at the company. A message should be visible "You are now viewing Google+ as XXXXX page". When you are on the profile with this message then take just the number part from the URL from there. That should work. If not let me have the full URL of the page you want to link to and I will see if I can get it working.

    Yes the number of tweets to show was for a old version of the Twitter widget which is now depreciated. I will get this sorted with the new version in a later update.

    Thanks,

    Alex

  7. MarlyM
    Member
    Posted 7 months ago #

    Hmm, still no luck with Google+. I tried what you suggested, but it's the same user ID as before, and it didn't make a difference.

    Also, while I was logged in as the page, I got the option to change my user ID to +[Google plus name], so I did. When I entered this new user ID, it did not work either.

    No worries about Twitter. I know which code you're talking about because I have it in an old site too. I'm guessing it was deprecated because they wanted to add the "Load more tweets" option into the mix. Hoping that they release more options in the future.

  8. StressFree Sites
    Member
    Plugin Author

    Posted 7 months ago #

    Hi,

    Can I have the URL of the page you are trying to embed I will try at my end?

    Sometimes 3rd party applications didn't like it if the same IP address keeps trying to access a widget. This might be happening with you.....

    Alex

  9. MarlyM
    Member
    Posted 7 months ago #

    Don't worry about it. I tried from another IP, and it's still not working. Thank you for your offer though. Take care.

  10. MarlyM
    Member
    Posted 7 months ago #

    What should the z-index be set to so that the Social Media Badge Widget (re: LinkedIn) shows up in the foreground? I thought I had read < 75 somewhere, but I'm not sure where.

    Not sure if I'm not going low enough with the my main content's z-index, or if I just edited the wrong one z index by mistake. Thank you.

  11. StressFree Sites
    Member
    Plugin Author

    Posted 6 months ago #

    Hi,

    The z index is a relative quantity. This means what shows in front is the element higher z index value compared to the other element. It is not the case a z index with 75 will always appear in front. Have a look at this example, the red box you can change the z index and you can see if appearing in front of the different elements as appropriate.

    http://www.w3schools.com/cssref/playit.asp?filename=playcss_z-index&preval=2

    This means you need to specify a z index of every element between the linked in widget and the main elements on your website. Increase the z index more than the previous to get it to be shown in front.

    I hope that helps.

    Alex

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.