WordPress.org

Ready to get started?Download WordPress

Forums

WP Last Login
[resolved] Last Login Column just shows a long digit string 1369638317 (12 posts)

  1. allmyhoney
    Member
    Posted 1 year ago #

    Hi there, I have installed the plugin on 3.5.1 of WordPress and tested out a few logins and my "last login colum" just gives me a big number rather than a date or some simple english text. This is what I get in the column: 1369638317 any ideas on this?

    http://wordpress.org/extend/plugins/wp-last-login/

  2. shamburg
    Member
    Posted 1 year ago #

    I have the same issue. are there any solutions?

  3. AurbeyM
    Member
    Posted 1 year ago #

    I think that it must have something to do with the theme. I have two sites, one uses Custom Community and the other Mantra. The Mantra site displays fine but the CC site just displays the raw date.
    It must have something to do with a conversion routine that is not working. The number you see IS a date, your number is really Monday, May 27, 2013 3:05:17 AM. Since the author isn't chiming in I'll see if I can track it down when I have some time.

  4. Konstantin Obenland
    Theme Wrangler
    Plugin Author

    Posted 1 year ago #

    Hm, I'm sorry to hear that. I thought I had that fixed with the last update.
    Do you use v1.2.1?

  5. AurbeyM
    Member
    Posted 1 year ago #

    I can't speak for the others but I am on version 1.2.1

  6. shamburg
    Member
    Posted 1 year ago #

    I am also on 1.2.1

  7. Konstantin Obenland
    Theme Wrangler
    Plugin Author

    Posted 1 year ago #

    This really sucks. :(

    Do you have access to the code file?

    Could you replace line 128

    $last_login = (int) get_user_meta( $user_id, $this->textdomain, true );

    with

    $last_login = absint( get_user_meta( $user_id, $this->textdomain, true ) );

    and see if this changes things?

    Could you deactivate all other plugins to see if this causes it maybe?

  8. shamburg
    Member
    Posted 1 year ago #

    that didnt help I got the following:

    Parse error: syntax error, unexpected '&' in /home/content/10/9234210/html/wp-content/plugins/wp-last-login/wp-last-login.php on line 128

    I cannot deactivate my other plugins. I am running a business on my site.

  9. AurbeyM
    Member
    Posted 1 year ago #

    Ok, it is a conflict.
    I updated the code but it made no difference (I didn't get a parse error)
    I disabled all my plugins and it worked. The dates were showing up properly. I re-enabled the plugins one at a time and when it came to WP-Members plugin it stopped working. As soon as I disable the WP-Members plugin the WP-Last Login dates display properly. That makes sense as the other WP site I have does not use the WP-Members plugin.
    I hope we can find a solution as I would like to be able to use both plugins.

  10. shamburg
    Member
    Posted 1 year ago #

    confirmed. The conflict is with Wp-Members.

  11. Konstantin Obenland
    Theme Wrangler
    Plugin Author

    Posted 1 year ago #

    Okay, I just opened a new issue in the WP Members support forum about it.
    About this allow me to set this thread to "resolved". :)

    Thank you so much guys for following up on it and tracking it down!

  12. AurbeyM
    Member
    Posted 1 year ago #

    Here is the fix. The author of WP-Members has put out a patch that you can apply right away or you can wait until the next release (2.8.3)
    I have applied the patch and it works.
    http://rocketgeek.com/blog/wp-members-2-8-2-user-table-column-error-patch/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.