WordPress.org

Ready to get started?Download WordPress

Forums

Large (64M) WXR import doesn't work, even with php.ini, etc. tweaks (2 posts)

  1. Peter Kirn
    Member
    Posted 3 years ago #

    I'm trying to import nearly a 64M WXR file. I've tried all the tweaks I've found in threads like this one:
    http://wordpress.org/support/topic/phpini-problem-not-allowing-20mb-file

    That is, I modified - in this case the *root* php.ini - in order to increase:
    * timeout limit
    * max input time
    * post max size
    * upload max filesize
    * memory limit

    ... as well as MySQL's query time max, AND wp-settings' own memory limit.

    What I find especially disturbing is that after doing all of that, the upload times out in exactly the same place -- about 3% into the upload, or 30 seconds. That doesn't make any sense; I'd think it'd at least get further before failing.

    I should note that I'm running nginx, but I know of no directive that'd have an impact here, only php.ini.

    So I wonder what else might be making this die? I'm going to use the WXR splitting technique for now, but I'm concerned in case anyone hit the same problem.

  2. This works very well: http://www.rangerpretzel.com/content/view/20/19/ Split the file down into ~2 meg chunks.

Topic Closed

This topic has been closed to new replies.

About this Topic