WordPress.org

Ready to get started?Download WordPress

Forums

Quiz Master Next
[resolved] languages support (14 posts)

  1. shrpne
    Member
    Posted 5 months ago #

    All text in russian transforms to "???????"
    Please add support for different languages. i guess switching to UTF8 will solve this

    https://wordpress.org/plugins/quiz-master-next/

  2. fpcorso
    Member
    Plugin Author

    Posted 5 months ago #

    Greetings shrpne:

    Thank you for choosing to use this plugin!

    I am currently working on adding multilingual support. I should have it ready within a few updates for you!

    Best Regards

    Frank

  3. darkdream
    Member
    Posted 4 months ago #

    If You want I can help You translate to polish language :)

  4. fpcorso
    Member
    Plugin Author

    Posted 4 months ago #

    shrpne:

    If you have a moment, can update to the newest version of the plugin and after ensuring your WordPress is set up for UTF8, please try to enter russian in again. I have had another russian user successfully enter russian text into some fields. We are still working to make sure it works in all fields, but it should be ready soon.

    ~Frank

  5. fpcorso
    Member
    Plugin Author

    Posted 4 months ago #

    Greetings darkdream:

    Thank you for choosing to use this plugin!

    Thank you for your offer of polish translating! I am almost finished getting the plugin setup for translations and once finished I will get back to you on this.

    Thanks again for your offer! I greatly appreciate any assistance.

    Best Regards

    Frank

  6. darkdream
    Member
    Posted 4 months ago #

    I have the same problem what shrpne - when i ad the question it don't display correct properly characters polish language only "?"

  7. darkdream
    Member
    Posted 4 months ago #

    Hello. I have solution to change "????" to normal characters. You must change language in your database MySql. Probably in Yours MySql You have latin swedish. You must change one by one the coding language in tables to utf8_general_ci.

    In this way, I solved the problem! :) :)

  8. imagospot
    Member
    Posted 4 months ago #

    Hello darkdream, I follow your solution, but it still doesn't display correctly polish characters in questions.

    This is my database: http://imagospot.pl/utf8.PNG

    Could you tell me what I do wrong?

  9. darkdream
    Member
    Posted 4 months ago #

    Hello,

    You must change language:
    1. In the general setting php my admin
    2. one by one the coding language in tables to utf8_general_ci or polish
    3. and one by one the coding language in line in the individual tables to utf8_general_ci or polish

    IMAGE

  10. imagospot
    Member
    Posted 4 months ago #

    Hello,
    I didn't know about your last point, but I found the solution:

    ALTER TABLE wp_mlw_qm_audit_trail CONVERT TO CHARACTER SET utf8;
    ALTER TABLE wp_mlw_questions CONVERT TO CHARACTER SET utf8;
    ALTER TABLE wp_mlw_quizzes CONVERT TO CHARACTER SET utf8;
    ALTER TABLE wp_mlw_results CONVERT TO CHARACTER SET utf8;

    Thanks!

  11. darkdream
    Member
    Posted 4 months ago #

    It Exactly what I meant :)

  12. kamuzon
    Member
    Posted 4 months ago #

    convert tables to utf8_general_ci with phpMyAdmin also works
    Thanks.

  13. Netz
    Member
    Posted 4 months ago #

    Hi,

    Translate works for me.. Except dates
    They show up in US format with 12th and so??

  14. shrpne
    Member
    Posted 4 months ago #

    Update or reinstall 2.3.1 version not worked for me.

    but imagospot solution worked well, thank you!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags