WordPress.org

Ready to get started?Download WordPress

Forums

Bogo
[resolved] language switcher, pages and search translation (5 posts)

  1. sftmb4
    Member
    Posted 1 year ago #

    hi Miyoshi-san,

    So far, i'm really enjoying Bogo and it seems alot more straightforward and simple compared to other options out there.

    Being somewhat of a wordpress noob, I have some questions and could use some clarification on a few things. This might not be the best channel to post in, but it seemed relatively active. :p

    here's my current site, for which I've got the bogo widget installed for the language switching.

    http://domofactor.com

    1. Instead of clicking on the switcher link, is there a way to automatically switch to domofactor.com/ja based on the client's locale? My initial thought was that this would be to be set via some apache tweaking.

    EDIT: Looks like I just needed a mod_rewrite with a rewrite condition of the accept-language header! ^_^

    2. when you search for something on my site that doesn't exist i'm still getting the default english for some reason. I've verified that I do infact have the japanese translation files there for my theme, as well as the ja.mo file I pulled from the wordpress repo here.

    <user>@<server>:/var/www/domofactor.com/wp-content/themes/zbench/lang# ls | grep ja
    ja_JP.mo
    ja_JP.po
    
    <user>@<server>:/var/www/domofactor.com/wp-content/languages# ls
    ja.mo

    3. Its possible that this is a bug, but when trying to do the same thing as posts, with pages, I noticed that all 4 pages show up regardless of which language I switch to. Also, when displaying a list of pages, japanese shows up as a listed locale, but for the default english pages, its just blank.

    Screenshot

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Can't see your site. Maybe due to incorrect rewrite rules.

  3. sftmb4
    Member
    Posted 1 year ago #

    ah, sorry about that. Should be viewable now. ;)

  4. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    <user>@<server>:/var/www/domofactor.com/wp-content/themes/zbench/lang# ls | grep ja
    ja_JP.mo
    ja_JP.po
    
    <user>@<server>:/var/www/domofactor.com/wp-content/languages# ls
    ja.mo

    I'm not sure what your problem is, but note that ja_JP and ja are two different locales. Maybe you should use only ja.

    3. Its possible that this is a bug, but when trying to do the same thing as posts, with pages, I noticed that all 4 pages show up regardless of which language I switch to. Also, when displaying a list of pages, japanese shows up as a listed locale, but for the default english pages, its just blank.

    Still not sure, but as long as I see in the screenshot, it's showing all locales. Check the drop-down menu "Show all locales" above the page list and the Locale column next to the Author column.

  5. sftmb4
    Member
    Posted 1 year ago #

    ah okay, thanks for the tips, i'll try that then!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags