WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Language switcher doesn't appear in menu (12 posts)

  1. veterantehnika
    Member
    Posted 1 year ago #

    Hello everyone!

    I have searched the forum here and via Google but I havent got any solution to my problem.
    I had older versions of polylang and wordpress and the language switcher wasn't seen in the menu. Then I updated polylang first (v.0.9.8) and wordpress later (v.3.5) and still the switcher doesn't appear in the menu. I'm using Twenty-Eleven theme and I have also tried Twenty-Ten, both standard/unmodified. I don't even know where exactly it should appear, I think it should be like seen in this page?: http://www.ab-newsonline.com/en/

    I have posts in three languages and when I type the aadress and the language code to the aadress bar, the language is seen (www.veterantehnika.ee/en or /de).
    Finally I figured out that the switcher can also be dragged to the sidebar and it works fine there but I still want it to the menu bar so it would be visible in all pages not only in HOME page.

    The webpage itself is here: http://www.veterantehnika.ee

    I also show U a few pictures of settings menu of polylang in the wordpress to show if everything should be OK with it: http://www.flickr.com/photos/62614585@N04/8386810453/sizes/l/in/photostream/
    and
    http://www.flickr.com/photos/62614585@N04/8387897716/sizes/l/in/photostream/

    Big thanks in advance if anyone could help me out.
    Mart Naagel

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    The language switcher can be added only to custom menus (currently you use the default menu, not a custom menu).

    You must first create one menu per language in Appearance->menus
    The go to Settings->Languages->menus
    Set the correct menu for each language
    And finally, check "Displays a language switcher at the end of the menu".

  3. JustMeSander
    Member
    Posted 1 year ago #

    I experienced a problem, when you don't have items in the menu , the language switch isn't displayed.

    I added to those menu's an menu item and i hide with with css for now.

  4. veterantehnika
    Member
    Posted 1 year ago #

    Hmm...

    I tried and f****d it all up big time. I tried to create the menus (which I don't understand why I have to create because I already have Menus in every language, but not in the Appearance->menus). Anyway I created them but I didn't get the correct menu items in place and then I deleted the menus and the whole site went down and all pages and posts also. I have been trying to restore the site for hours now and it still isn't absolutely OK again. Switching to english still doesn't work any more. I'll try again another day, it's in the middle of the night here in Europe :)

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @veterantehnika

    Are you sure that posts and pages disappeared? Or are they simply not displayed on admin side due to the language filter? Look at the languages menu in the admin toolbar on top of your screen.

    which I don't understand why I have to create because I already have Menus in every language, but not in the Appearance->menus

    When you don't set a custom menu, most themes fallback to the list of pages and I can't add the language switcher to that list of pages.

    @JustMeSander
    I reproduced this. This issue appeared with WordPress 3.5 due to this ticket. And I can't work around this without changing a lot of code. So I will not change this in 1.0 but will try to work on it later.

  6. veterantehnika
    Member
    Posted 1 year ago #

    Hello again!

    I finally figured it out how it works. :) But the problem is that I have this dropdown menu under Gallery http://veterantehnika.ee/en/ but if I use custom menu then I lose the dropdown menu. Is it still possible to have it when using this custom menus?

    Thanks in advance!

    Mart

  7. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

  8. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I experienced a problem, when you don't have items in the menu , the language switch isn't displayed.

    This problem will be solved in Polylang 1.1 as the language switcher will be a menu item as the others. For more information on this new version and how to test it (not for production site yet), see:
    http://polylang.wordpress.com/2013/04/17/you-can-start-to-test-polylang-1-1/

  9. jan.mach71@gmail.com
    Member
    Posted 8 months ago #

    Hi, I have polylang 1.1.6 and WP 3.7.1 and I cannot find how to add language switcher into menu. I have created through Appearance -> menu english and russian menu, and I cannot see anywhere any drag & drop not checkbox which would allow to add language switcher to menu.
    Thankx for some guidance

  10. jan.mach71@gmail.com
    Member
    Posted 8 months ago #

    ok, theme is customizr, maybe it does not support it, who should know...

  11. Chouby
    Member
    Plugin Author

    Posted 8 months ago #

  12. jan.mach71@gmail.com
    Member
    Posted 8 months ago #

    nicely hidden, no I did not read that, as I came google up some rather misleading web page...

    thank you anyway, my web's closer to final version now ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic