WordPress.org

Ready to get started?Download WordPress

Forums

language not working (20 posts)

  1. baga
    Member
    Posted 7 years ago #

    hi everybody,
    it seems that i'm not the only one having this problem but i haven't understand how to solve it:
    i worked on a local copy of my website, installed worpress, everything worked fine.
    after i uploaded all the files and database on the web server i noticed that my admin panel only shows up in english and not in italian which is my language.
    i did upload the files it_IT.mo and it_IT.po and i did setup the file wp-config.php adding define ('WPLANG', 'it_IT');
    i emailed the hosting provider but they have no idea on how to solve this problem.
    if anyone can help, it will be very appreciated
    thanx

  2. moshu
    Member
    Posted 7 years ago #

    One thing you can ask your host if the gettext module is enabled on their server.

  3. baga
    Member
    Posted 7 years ago #

    thanks moshu, i have just asked them, i will let you know their answer.
    thanks a lot

  4. baga
    Member
    Posted 7 years ago #

    hi moshu,
    i have just received the answer from my hosting provider, they wrote: "Yes, we do have the gettext module installed on our servers. It is located in /usr/bin/gettext"
    what would you suggest me to do now?

  5. baga
    Member
    Posted 7 years ago #

    ANYONE CAN HELP???

  6. moshu
    Member
    Posted 7 years ago #

    In that case everything should work fine.
    Is the it_IT.mo file in the right place? (you need only the mo file, not the .po file)

  7. baga
    Member
    Posted 7 years ago #

    the file it_IT.mo is in the directory wp-includes\languages
    i tried to look for help in other forums too but still can't find the answer :-(

  8. baga
    Member
    Posted 7 years ago #

    ANYONE CAN HELP???

  9. boetter
    Member
    Posted 7 years ago #

    Did anyone figure this out? I am having the exact same problem, just using a danish translation.

  10. emilgb
    Member
    Posted 7 years ago #

    Jupp same problem, Im trying to install a norwegian language file
    I have two diffrent blogs on two diffrent servers, I cant figure out why it dont load the language file.
    I have changed the wp-config.php correct :

    define ('WPLANG', 'nb_NO');

    And upladed the file to the folder :
    (mywordpressinstallationfolder) wordpress\wp-includes\languages\nb_NO.mo

    And this worked on the one server but on the other one it didnt. The one I have the problem on is runing:

    Operating system Linux
    Kernel version 2.6.9-42.0.3.ELsmp
    Machine Type x86_64
    Apache version 1.3.37 (Unix)
    PERL version 5.8.7
    PHP version 5.2.1
    MySQL version 4.1.21-standard

    I have tryed to modify gettext.php to get things runing... but not so far.

    Im dont know if the server have gettext module enabled, I have mail them to figure this out, But so far I dont have any idea of why this would`nt work... someone please help me out.. I see others have the same problems ;)

  11. emilgb
    Member
    Posted 7 years ago #

    jupp got my answer, they where runing with gettext module enabled
    ... People... what is wrong? somebody please direct me towards innlightenment or what you call that stuff.. please lett there be a coder that sees this cryout for help :)

  12. MDD
    Member
    Posted 7 years ago #

    php 5.0 bug was corrected be entry in gettext.php file (wp-includes). This correction does not work with php 5.2.1

    You need to edit gettext.php file

    Find entry:

    if ($magic == ($MAGIC1 & 0xFFFFFFFF)) { // to make sure it works for 64-bit platforms
    $this->BYTEORDER = 0;
    } elseif ($magic == ($MAGIC2 & 0xFFFFFFFF)) {

    Replace by:

    if ($magic == $MAGIC1) {
    $this->BYTEORDER = 0;
    } elseif ($magic == $MAGIC2) {

    The solution was described there: http://wordpress.dk/forum/topic/19

    It is working for me. WordPress 2.1.3 php 5.2.1

  13. wifi_jirka
    Member
    Posted 7 years ago #

    Hi, I have exact problem with language in admininitration section.

    - Module gettext is enabled

    I tried solution above, but it did not help in my case. Contrariwise, everything is much worse. Some text are OK now (in czech language), but some are still in English (just one half of administration menu).
    And some text became unreadable becouse there are now some "Egypt" characters.

    php 5.2.1
    wordpress 2.1.2
    gettext enabled

    Any idea ?

  14. kenanoff
    Member
    Posted 7 years ago #

    Hi, Sorry for double-posting, but this seems to be more developed thread. I have the same problem, localization was OK until last week, then disappeared.

    My system is:
    php 5.2.3
    MySQL 5.0.41
    gettext enabled (according to my host)
    wordpress 2.1

    Can please someone help on this?

  15. kenanoff
    Member
    Posted 7 years ago #

  16. mdsmds
    Member
    Posted 6 years ago #

    The bug hasn't been fixed so far, it's still included in 2.3.1-beta1. When can we expect a bugfix for this nasty problem?

  17. MichaelH
    Member
    Posted 6 years ago #

    mdsmds - has that bug been reported to Trac?

    Resource:
    Reporting_Bugs

  18. marcwillow
    Member
    Posted 6 years ago #

    I have this problem with

    WordPress 2.3.1
    PHP 5.2.3
    MSQL 5.0.27-standard.

    No matter what language files I put in WP they are not applied even though I edit wp-config as needed.

    Any ideas what to do?

  19. ibear
    Member
    Posted 6 years ago #

    I have the same problem.

    WordPress 2.3.1
    PHP 5.2.3
    MySQL 4.1.22

  20. Zhiz0id
    Member
    Posted 6 years ago #

    Thank you kenanoff
    This solution is working.

    System: OpenSuse 10.3 x86_64 PHP 5.2.4

    If someone don't understand, you must fix gettext.php file and localisation should work on x86_64 system(wp 2.3.1).

    wp-includes/gettext.php:122

    $this->BYTEORDER = 0;
    // $this->error = 1; // not MO file
    // return false;

Topic Closed

This topic has been closed to new replies.

About this Topic