WordPress.org

Ready to get started?Download WordPress

Forums

Transposh WordPress Translation
[resolved] language not detected automatically (11 posts)

  1. sunlight1976
    Member
    Posted 1 year ago #

    Hi,
    great plugin!
    I have a problem with website http://www.isocial.it
    Translation and manual language selection are working great, but website is not detecting automatically user language.
    P.E. if you open the website from USA it is shown in italian, not in english.
    I enablet autodetection in settings.
    Can you help please ?

    thank you

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    The autodetect is based on the browser language specifications and not on any geoip data, so what you describe may happen.

    Since the geoip work was never done (and no one ever choose to sponsor that) I can't really help at this point

  3. sunlight1976
    Member
    Posted 1 year ago #

    Thanks, but is not working with browser language too:
    I have 2 browsers, one set in italian and the other in english.
    When I open colnect.com with the italian one it speaks in Italian, with the english one it speaks english.
    My website is always in italian with both browsers, could you try please?
    Thanks

  4. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, I agree that it does not work.

    The redirect is not happening, for one reason or the other.

    If you wish, I might be able to debug this, but I will need credentials to your site, please contact via the contact from on transposh.org

  5. sunlight1976
    Member
    Posted 1 year ago #

    I will create a WordPress account got you!
    In the meanwhile, I tried to switch my iPhone language to English.. And language auto detect is working with safari, but not with chrome. Quite strange, isn't it?

  6. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, strange

    I did try on FF here.

  7. sunlight1976
    Member
    Posted 1 year ago #

    In Firefox in which language?
    I

  8. sunlight1976
    Member
    Posted 1 year ago #

    User created, credentials in your website contact form!
    Take a look in HTML source code.. I think language definition is missing..

  9. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Sent a direct message, I could not fix this, and I think some caching solution is messing the redirection up, this is not related to the html (which is created after the redirection)

    Sorry

  10. sunlight1976
    Member
    Posted 1 year ago #

    Hi Ofer,
    find it with your precious suggestions: it was WP-Minify plugin.
    Maybe I should exclude something in its actions.

  11. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the information, I'll update our wiki :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags