WordPress.org

Ready to get started?Download WordPress

Forums

Export User Data
[resolved] Language issue - cannot export non-english characters (9 posts)

  1. MDS
    Member
    Posted 10 months ago #

    hi, everything works fine except that it cannot export non-english characters, they all become garbled in the exported file.

    http://wordpress.org/plugins/export-user-data/

  2. qstudio
    Member
    Plugin Author

    Posted 10 months ago #

    @ssjaimia - this sounds like an encoding problem - I will need to check the plugin to see if it's set correctly to use UTF-8.

    I'll get back to you when I've got some time in the coming days :)

    Q

  3. qstudio
    Member
    Plugin Author

    Posted 10 months ago #

    @ssjaimia - are you trying to export to CSV or Excel and are you trying to open the exported file on Mac or PC - so I can try and pin down the issue?

    Q

  4. MDS
    Member
    Posted 10 months ago #

    both CSV and Excel have the same issue, i'm using MAC, but it doesn't seem related to the OS

  5. qstudio
    Member
    Plugin Author

    Posted 10 months ago #

    @ssjaimia - from what I read, there is an important difference with how Mac handles UTF-8 data - however, I don't have a Mac to test on.

    I tried adding something called a UTF-8 BOM - but I've not had much luck so far and not much time to test.

    Could you try and find a way to test the plugin on a PC and see if there is any difference - if not, as least I'll know that I'm looking in the wrong place for answers :)

    Q

  6. MDS
    Member
    Posted 9 months ago #

    hi, i tried to export data in PC, result is still the same.

  7. qstudio
    Member
    Plugin Author

    Posted 9 months ago #

    @ssjaimia - thanks for the follow-up message.

    I can now replicate the problem, but I don't have a lot of time to find a solution right now - as soon as I do, I'll release an update - sorry for the delay!

    Q

  8. qstudio
    Member
    Plugin Author

    Posted 8 months ago #

    Hey - the latest update of the plugin should have addresses this foreign character problem - if you still use the plugin, please check again.

    Thanks

  9. qstudio
    Member
    Plugin Author

    Posted 7 months ago #

    I'm closing this request - as no reply from the author.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.